Bukkit MyPet-NPC 1.4

Simple addon for MyPet that adds Citizens-traits

  1. I thought i did but i didnt, uploaded the wrong file by mistake... its working now, thanks!
     
  2. i was put this plugins in my server and i have one error to compatibility.
     
  3. Using NPC 1.1 and mypet 2.2.6

    I have put all permissions in and I can not get the NPC to give the "hand over pet" option as a normal user, it only opens the pets switch screen. If I issue the /petswitch store command, then it does store the pet, The NPC just won't get you the option to hand over the pet.

    BUT if I am Opped, it get the option to hand over my current pet.

    I've dug through the wikis and tried every permission. Am I missing something? thanks!
    ____

    Solved the issue - had a mistype in petstorage limit permission that I overlooked 39 times. Thanks!
     
    #46 Apbreck, Sep 9, 2016
    Last edited: Sep 9, 2016
  4. using mypet premium 2.3.1
    and latest devbuild (also tried latest release)

    getting 9/22/2016 8:06:17 AM [INFO] [MyPet-NPC] MyPet is not installed/enabled. Activating dummy traits! on start up
     
  5. fixed it myself, moved mypet from softdepend to full dependancy in the plugin.yml
     
  6. Do you use a plugin-reload-plugin?
    Could you post the full log with the error in it?
     
    #49 Keyle, Sep 23, 2016
    Last edited: Sep 23, 2016
  7. I do not use a plugin management plugin.
    I posted the full error on the discord page, but it was only the load order, it tried to load mypetnpc before mypet premium, by changing it to a dependency it waits until its loaded.
     
  8. I need version to 1.10.2, please!!!

    Java 8!

    T-T
     
  9. I'm running this on 1.10.2 and java 8 with no issues.
     
    • Agree Agree x 2
  10. I think there is a bug. When I allow players to tame mobs the mob goes invisible. Its still there and will attack mobs once you attack but the mob is not rendered after taming it. I am on a 1.11 server.
     
  11. MyPet Issues.

    I'm having a problem at MyPet when my friend tried to pick up a baby pet did not work. And there's no way to get pets baby, what do I do?
     
  12. Having a problem in 1.12 where some people randomly arent allowed to use the npc. They have the correct perms and people with the same perms do not have the issue.
     
  13. Will you ever add armor effect to pets? and do weapons do more damage?
     
  14. Wrong plugin and no.
     
    • Funny Funny x 1
  15. Hi, im getting this on server start - any ideas? server 1.12.1

    Code (Text):
    11.08 11:08:48 [Server] INFO at java.lang.Thread.run(Unknown Source) [?:1.8.0_111] 11.08 11:08:48 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:323) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:374) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[Spigot.jar:git-Spigot-a22b705-5717601] 11.08 11:08:48 [Server] INFO at de.keyle.mypet.npc.MyPetNpcPlugin.onEnable(MyPetNpcPlugin.java:94) ~[?:?] 11.08 11:08:48 [Server] INFO java.lang.NoSuchMethodError: de.Keyle.MyPet.util.Metrics.<init>(Lorg/bukkit/plugin/Plugin;)V 11.08 11:08:48 [Server] ERROR Error occurred while enabling MyPet-NPC v1.1.0 (Is it up to date?)
     
  16. Oops, I forgot to upload the latest version... Sorry
     

Share This Page