Mythic mobs error

Discussion in 'Spigot Plugin Help' started by CoderBoyo, Jun 21, 2021.

  1. I'm using minecraft 1.16.5 and just downloaded the newest mythic mobs version (free) I get this error when trying to summon in one of the build in mobs (charged sheep):
    Code (Text):
     [MythicMobs] [SCHEDULER] Exception thrown whilst executing task
    [21:28:25] [Craft Scheduler Thread - 68/WARN]: java.lang.NoSuchMethodError: 'net.minecraft.server.v1_16_R3.Chunk net.minecraft.server.v1_16_R3.World.getChunkIfLoaded(int, int)'
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.volatilecode.v1_16_R3.VolatileWorldHandler_v1_16_R3.getEntitiesNearLocation(VolatileWorldHandler_v1_16_R3.java:177)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.targeters.LivingInRadiusTargeter.getEntities(LivingInRadiusTargeter.java:32)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.AbstractSkill.evaluateTargets(AbstractSkill.java:430)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.SkillMechanic.executeSkills(SkillMechanic.java:366)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.SkillMechanic.execute(SkillMechanic.java:324)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.SkillManager.executeMobTimerSkills(SkillManager.java:377)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.skills.SkillManager.runTimerSkills(SkillManager.java:359)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.clock.MythicMobsAsyncClock.run(MythicMobsAsyncClock.java:21)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.utils.Delegates$RunnableToConsumer.accept(Delegates.java:93)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at io.lumine.xikage.mythicmobs.utils.Schedulers$LumineTask.run(Schedulers.java:162)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at org.bukkit.craftbukkit.v1_16_R3.scheduler.CraftTask.run(CraftTask.java:81)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at org.bukkit.craftbukkit.v1_16_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:54)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
    [21:28:25] [Craft Scheduler Thread - 68/WARN]:  at java.base/java.lang.Thread.run(Thread.java:831)
    I might be stupid but maybe this version isn't compatible with 1.16.5?
    I tried to report this but i didn't find a place to, please let me know if there is.

    - CoderBoyo
     
    • Friendly Friendly x 1
  2. I have messaged the author
     
  3. Then Just wait.
     
  4. I have just messaged the author I didn't message him before this post
     
  5. What Java is your server running on?
     
  6. Java 16
     
  7. That may be the problem. If you can, try to downgrade to Java 11
     
  8. I dont think there should be a problem with Java 16, since the error says that it cant find "net.minecraft.server.v1_16_R3.Chunk". And this seems to be a plugin issue.
     
  9. Because it uses reflection and that might change from java 8. Also it would be better to use the native (8) Java anyway
     
  10. Plugins I use including mine only support java 16 but I'll look into it
     
  11. I was not able to downgrade to java 11 as almost all plugins including mine only support java 16 and is specifically configured to work with java 16
     
    • Informative Informative x 1