Nether difficulty setting

Discussion in 'Spigot Help' started by Sdrex, Jul 16, 2020.

  1. Hello everyone,

    I'm new to the forums,

    In a server I'm hosting with some friends, the nether diffiulty setting is always in peaceful, regardless of the server difficulty setting (this does not change even if I try to manually set the difficulty in the nether)

    The server build is git-Spigot-05da6fa-b0c6dfe (MC: 1.16.1) (Implementing API version 1.16.1-R0.1-SNAPSHOT)

    Attached is a screenshot of the results of the commands given by op to try and change the difficulty difficultysetting.PNG

    Thanks for your kind help,
    Best regards
     
    • Agree Agree x 1
  2. Hi
    I am having the same problem! The world_nether is always in easy. Even with multiple nether worlds added later to test with multiverse core.
    In the moment I am searching the cause of this problem. I have not much knowledge of servers but I am sure this has something to do with spigot/bukkit ore the plugins we have installed on the server.
    In the following days i will test this without any plugins and with vanilla.

    Please vote this bug up!

    SteelheartHD
     
  3. If you are using a world management plugin (ie Multiverse), check the 'worlds' configuration file.
    And use the appropriate command for the world manager.
     
  4. Hi!
    Thanks to both for your replies,
    we are not uising any world management plugin...

    little update, the client after exiting the nether thinks that you are playing in peaceful, and as such does not update correctly hunger and health (I really don't know if this new info is gonna help, but we noticed this today)
     
  5. I have just finished installing my first 1.16.1 server upgrade from version 1.15.2 and have noticed a few configuration changes.

    If you have upgraded to this version? ensure that you are using the new file versions of ...
    bukkit.yml
    server.properties
    spigot.yml

    'spigot.yml' contains some additional/altered setting for the world creation seeds
    Code (Text):
    world-settings:
      default:
        seed-bastion: 30084232
        seed-fortress: 30084232
        seed-mansion: 10387319
        seed-fossil: 14357921
        seed-portal: 34222645
    Do use a new/latest release as there was a configuration file replace/update error in one of the earlier versions.
     
  6. Hey, I bought a server on Hicoria hosting, but they wont help me. So my problem is, that the pigmans,piglins, wither skletons and ghasts wont spawn in nether. Problem is not the render distance, i have my server on hard difficulty and they wont spawn. There are no mobs in our nether. I tried restarting the server, but it didnt help. Mobs in overworld are spawning as they should.The output is 1,5GB of RAM, the version of the server is 1.16.1. I bought CraftBukkit 1.16.1. version but mobs wont spawn there in nether.
     
  7. Hi, we upgraded the server from 1.15.2 to 1.16.1 but had the world recreated from scratch.

    As far as I can tell it doesn't seem to be a configuration missing problem (the server checks if some config options are missing when it loads, and it does not give any error, also i tried searching in spigot.yml the seeds you quoted and they are all presents there, so i think the upgrade process went right).

    Sorry for the newbie question, where can i check to see if the configuration files are up to date?

    Thanks for your kind help
    BR
     
  8. Hello again,

    sorry for the bump,

    I managed to fix this problem, and would like to share spigot's behaviour in this problematic so that it might be useful to others.

    - First of all we are using multicraft to manage our server, we were playing on a 1.15.2 server until the release of 1.16.
    - Then we started a new server by simply telling multicraft to use a different world under 1.16.
    - We noticed that the difficulty was set to peaceful (in the conf file it was on normal, in multicraft we found it set as easy), so we changed that to normal and expected that to fix the problem.
    - We entered the nether and found that in the nether (and not in the overworld) the server still gave us a Peaceful difficulty setting(mobs despawned as soon as they spawned from spawners, didn't spawn entirely etc.).
    - Trying to change the difficulty setting resulted in nothing, as the server was actually set in normal, so the command resulted in "The game difficulty is already set to normal"
    - Through other means we went to the End to see if the problematic was there too, and confirmed it was a problem with both alternate worlds.
    - I then started a new test server with the same configuration files as the shared server( I copy pasted them after checking that generating a clean server with 1.16 gave the same configuration files as the ones i had in the shared server), to see if the problem was there too, the problem was not there.
    - Copying the world files to the new test server however reproduced the problematic entirely.
    - I then started rummaging through the level.dat of both the nether and the End, and found that in the level.dat both Difficulty and DifficultyLocked were at 0, changing Difficulty to 2 in both of them resulted in the problematic solved.
    - I still haven't tried changing the difficulty of the server, I will probably try to do so in the next days.

    The thing that seemed strange to me, is that by the Minecraft wiki if DifficultyLocked is set to 0, it should accept difficulty changes without problems, but for some reasons the server did not modify the level.dat accordingly to the server difficulty...
     
    • Friendly Friendly x 1
    • Useful Useful x 1
  9. THIS IS HOW TO FIX IT FOR ANYONE WONDERING AND DONT WANT TO RESET THE ENTIRE WORLD:
    Go to this LINK and download NBTExplorer. Then you want to open the level.dat file located in the Nether world folder and edit the line labeled difficulty. There you can change the difficulty directly from the source. Once you change that value, upload the file to your server if you're using a host and restart your server. That should fix it. Make sure to repeat the same thing if you need to change it for The End too.

    I looked in various threads and there was never a good solution in any of them, hence me "bumping" this post. Hopefully the next person after me doesn't need to struggle trying to figure this one out.

    EDIT:
    Apparently this didn't work for me.. It keeps resetting my level.dat files... Sigh sorry guys.
     
    #9 probmatic, Jun 15, 2021
    Last edited: Jun 15, 2021
    • Useful Useful x 2