Spigot NetworkCore 2.20.8

API for my other resources, comes with a hosted web-interface

  1. Darthmineboy updated NetworkCore with a new update entry:

    Purge old data

    Read the rest of this update entry...
     
  2. That error occurs (a lot) when you have not configured NetworkCore. I will release an update today that prevents the console from being spammed, but you will still have to configure NetworkCore.
     
  3. Darthmineboy updated NetworkCore with a new update entry:

    Fix setup errors

    Read the rest of this update entry...
     
  4. Having issues with alternative accounts, or just curious about your players? You can now view all users that joined with the same IPv4.
    1. Select a user
    2. Select the Connects tab
    3. Click the IPv4
    Website: https://www.networkcore.org/

    [​IMG]

    [​IMG]
     
  5. Darthmineboy updated NetworkCore with a new update entry:

    Easier translation

    Read the rest of this update entry...
     
  6. Is your server growing or shrinking? Check now under the Statistics tab.

    [​IMG]
     
  7. You can now view user activity on all your servers. Click the Users tab and then select Activity.

    [​IMG]
     
  8. Darthmineboy updated NetworkCore with a new update entry:

    Realtime Users Activity & Improved Configuration

    Read the rest of this update entry...
     
  9. SpaZMonKeY777

    Wiki Team

  10. https://stackoverflow.com/questions/6901108/the-total-number-of-locks-exceeds-the-lock-table-size

    Increase the innodb_buffer_pool_size, or try to delete some records out of the table using the following statement:

    This will delete 10000 records from the table. Try to increase the 10000 to the biggest batch possible.
    DELETE FROM ncore_server_log WHERE log_id IN (SELECT log_id FROM ncore_server_log LIMIT 0,10000)

    https://stackoverflow.com/questions/16459990/sql-error-0-sqlstate-08s01-communications-link-failure

    Might be a networking issue as suggested, I would suggest to restart your mysql service and see if that solves the problem.
     
  11. SpaZMonKeY777

    Wiki Team

    Tried restarting, tried increasing the buffer pool size, and tried deleting the batch records like you showed, and still getting this error: https://pastebin.com/rk17TpQ3

    I should note, I am finally updating my servers to 1.12.1 while updating to the newer version of NetworkCore and UltimateTickets.
     
  12. DELETE FROM ncore_server_log WHERE log_id IN (SELECT log_id FROM ncore_server_log LIMIT 0,10000)

    Did running the above statement work? If so, you could repeat to execute that until the amount of records is reduced sufficiently to not encounter the issue with a too small innodb_buffer_pool_size.

    Or alternatively you could empty the table completely
    Since it's just a table used to store logs I would suggest to empty it complete with the following SQL statement

    TRUNCATE ncore_server_log

    I am not sure whether this is affected by the innodb_buffer_pool_size, so you might run into the same issue.
     
  13. SpaZMonKeY777

    Wiki Team

    I found a different possible solution, and so far I have not seen the error. I simply increased the lock-wait-timeout to a higher number and so far it's working. Default was 50, so I bumped it just a little :p

    Code (Text):
    innodb_lock_wait_timeout=1000
    I will update if anything changes, and appreciate the help :)
     
  14. https://dev.mysql.com/doc/refman/5.7/en/innodb-parameters.html#sysvar_innodb_lock_wait_timeout

    I would reduce it back to 50 since the unit is seconds and not millis. I do hope that having this increased one-time that it was able to delete most records.
     
  15. Darthmineboy updated NetworkCore with a new update entry:

    Localization & Webinterface update

    Read the rest of this update entry...
     
  16. EDIT: I've been looking around in your source code, and it looks like you might be performing a SQL query on the "ncore_info" table before it has been created (see line 50 of networkcore/src/main/java/net/rieksen/networkcore/core/dao/mysql/MySQLInfoDAO.java).

    ORIGINAL POST:

    I'm afraid I'm experiencing an issue after installing NetworkCore for the first time. The mysql database connection information has been entered into the config file correctly and the server is then restarted. This is what appears in my console when the server loads the NetworkCore plugin:

    10.09 18:39:28 [Server] WARN 1450 [Server thread] INFO com.zaxxer.hikari.HikariDataSource - HikariPool-0 - is starting. 10.09 18:39:28 [Server] INFO [NetworkCore] Successfully prepared datastore! 10.09 18:39:28 [Server] WARN net.rieksen.networkcore.core.dao.DAOException: Failed to find all info 10.09 18:39:28 [Server] WARN at net.rieksen.networkcore.core.dao.mysql.MySQLInfoDAO.findAllInfo(MySQLInfoDAO.java:40) 10.09 18:39:28 [Server] WARN at net.rieksen.networkcore.core.info.InfoModule.refreshCache(InfoModule.java:43) 10.09 18:39:28 [Server] WARN at net.rieksen.networkcore.core.info.InfoModule.initModule(InfoModule.java:32) 10.09 18:39:28 [Server] WARN at net.rieksen.networkcore.spigot.NetworkSpigot.onEnable(NetworkSpigot.java:300) 10.09 18:39:28 [Server] WARN at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) 10.09 18:39:28 [Server] WARN at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) 10.09 18:39:28 [Server] WARN at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:402) 10.09 18:39:28 [Server] WARN at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:384) 10.09 18:39:28 [Server] WARN at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:333) 10.09 18:39:28 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422) 10.09 18:39:28 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383) 10.09 18:39:28 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338) 10.09 18:39:28 [Server] WARN at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) 10.09 18:39:28 [Server] WARN at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) 10.09 18:39:28 [Server] WARN at java.lang.Thread.run(Thread.java:745) 10.09 18:39:28 [Server] WARN Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'mc39927.ncore_info' doesn't exist 10.09 18:39:28 [Server] WARN at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) 10.09 18:39:28 [Server] WARN at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) 10.09 18:39:28 [Server] WARN at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) 10.09 18:39:28 [Server] WARN at java.lang.reflect.Constructor.newInstance(Constructor.java:423) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.Util.handleNewInstance(Util.java:425) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.Util.getInstance(Util.java:408) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:943) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3973) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3909) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:2527) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java:2680) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionImpl.java:2494) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.PreparedStatement.executeInternal(PreparedStatement.java:1858) 10.09 18:39:28 [Server] WARN at com.mysql.jdbc.PreparedStatement.executeQuery(PreparedStatement.java:1966) 10.09 18:39:28 [Server] WARN at com.zaxxer.hikari.proxy.PreparedStatementProxy.executeQuery(PreparedStatementProxy.java:52) 10.09 18:39:28 [Server] WARN at com.zaxxer.hikari.proxy.HikariPreparedStatementProxy.executeQuery(HikariPreparedStatementProxy.java) 10.09 18:39:28 [Server] WARN at net.rieksen.networkcore.core.dao.mysql.MySQLInfoDAO.findAllInfo(MySQLInfoDAO.java:31) 10.09 18:39:28 [Server] WARN ... 14 more 10.09 18:39:28 [Server] ERROR [NetworkCore] Failed to enable successfully
     
    #79 dehavenbooks, Sep 11, 2017
    Last edited: Sep 11, 2017
  17. I'll have a look when I'm at college if time allows, otherwise it will be in 5 hours that I can fix the issue.