New crash packets exploit hack client out in public

Discussion in 'Spigot Plugin Development' started by Golicraft, Sep 14, 2018.

Thread Status:
Not open for further replies.
  1. Hi there! I'm writing for the whole minecraft 1.8 community. In the past days a new exploit crash hack client has been released publicly at youtube. however the video is down but allot of people are re-selling this client for 25$. I have got the client and searching for a developer to make a public fix for this.

    Take contact with me at Discord:
    ⊕ム ɢᴏʟɪ ム⊕:#9401

    I have some requirements. The plugin will be uploaded by me at spigot to make sure it wouldn't be a plugin charged for money. Also, the Developer needs to know how to decompile a minecraft client and will need some experience with java.

    I have a video of a user that took down mc-central with 2000 players. Every 1.8 server is in danger. I hope anyone here have the experience, time and feelings to help these servers. Thanks!

    I will post the video if necessary.

    Some information about the crash exploits:
    - It is based on packets that are too big for the server to handle
    - This is new packets that none of the public spigot plugins patch for example:
    https://www.spigotmc.org/resources/custompayloadfixer-bungeecord-bukkit-spigot.39891/
    https://www.spigotmc.org/resources/bookpacketexploitfix.40982/
    and more.

    Edit: I own my own server: mc.golicraft.net and some players constant crash my server. It ruins it :(


    Take contact with me at Discord:
    ⊕ム ɢᴏʟɪ ム⊕:#9401
     
  2. Every hack client for 1.8 has that, and it will not work on a ton of 1.8 servers (unless it's PvP related or something) because the packets are most likely to be limited by ViaVersion or an anti-cheat.
     
  3. This is new limits with new packets and need to be patched like the others.
     
  4. Here's a fix: don't use software which has been outdated and unsupported for over 3 years.
     
    • Like Like x 2
    • Winner Winner x 1
    • Friendly Friendly x 1
  5. Thats not the point. And if everyone stops with 1.8 supported servers minecraft will die totally. 1.7 pvp was the best but 1.8 is great too. 1.9, 1.10, 1.11, 1.12, 1.13 just stop..
     
    • Optimistic Optimistic x 5
    • Informative Informative x 1
  6. just stop with commenting if you won't help. It isn't necessary and is just a pain in the ass .....
     
  7. you 1.8 people are a pain in the ass; using a piece of software which has been unsupported for 3 years while all acting and assuming like 1.8 is the only thing that matters and that everyone should help you with all of the issues that come with it

    Oh that's actually really nice.

    You're 16 versions behind.
    1493 bugs have been fixed in future versions.
    756 Spigot bugs have been fixed in future versions.
    This version is over 2 years old.

    They should add security patches to that list.
     
    • Agree Agree x 2
    • Like Like x 1
  8. Why u care? Move on and stop commenting if u won't help. just annoying but thanks for reminding that 1.8 is outdated because I didn't know that...
     
    • Optimistic Optimistic x 2
    • Funny Funny x 1
  9. Everyone has already stopped supporting 1.8 now that 1.13 is here. 1.8-1.12 was arguably doable in the case of supporting one supports the other but now we have reached a new checkpoint, just like 1.8 knocked out everything below that.
     
    • Agree Agree x 1
  10. Why would some1 code a fix for YOU if hes not even allowed to make any profit and YOU will upload his resource then?
    I mean would be nice if you get a free copy and he makes some money with it..
    Ps: Update your Server 1.8 is way to old/not supported anymore
     
  11. 2008Choco

    Junior Mod

    "How do you fix this exploit!?"
    "Update. It's fixed in x.y.z"
    "ARE YOU CRAZY WHY WOULD YOU SUGGEST THAT, WHAT'S WRONG WITH YOU!? I JUST WANT TO FIX THIS EXPLOIT!"

    This thread in a nutshell ^
    @OP, the only reasonable resolution to this issue is to update to the latest software. SpigotMC does not offer support for out of date versions, especially for issues that were patched literally the following version. Whether you like the combat or not is irrelevant. If you want to fix an exploit, take the measures to resolve it... update.

    Thread locked
     
    • Winner Winner x 10
Thread Status:
Not open for further replies.

Share This Page