New server, help!

Discussion in 'Spigot Help' started by ZaIgre, Jun 24, 2015.

  1. Hello everybody!
    I have a bukkit server for me and my friends for as year now. Because a lot of things now have bugs and problems I decided to start new server from the bottom. Now I have 1.7.9, but I would like to upgrade it to 1.8. I cant find how to update it. I actually dont understand what is Spigot, and difference between CraftBukkit and Bukkit? If I understand well, Pigot is updated CraftBukkit?
    And than plugins: I would like to make a server with multiple worlds:
    1. survival
    2. hungar games
    3. survival with shop
    4. fields with shop
    5. creative
    6. etc.
    I dont know how the lobby works, but i would like to have one, where the teleport will be to all of the worlds... Do i need a world just for lobby?
    Probably I will need plugins:
    1. world edit (to easily edit world, esspecially in the making lobby etc.)
    2. essentials (for all the permissions, prefixes, comands, for nicknames etc) do I need essntials core, essentials group manager or what?
    4. multiverse-core (for multiple worlds)
    5. multiverse-portals (for portals between worlds)
    6. plot me (for a world with fields)
    7. better shops (shop-economy)
    8. survival games
    So, do you agree with me, what are the best plugins to work with for my needs? I see a lot of servers are organised like this, and i would like to make the same...do you think this are suitable plugins for me, do you recomand any others?
    Thank you very much!
     
  2. Thank you very much for a reply!
    I manage to make spigot server 1.8.7. Now I would like to add some of the plugins: I allready added:
    -multiverse-core
    -multiverse-portals
    -world edit (in the log file i see some errors, but it works fine?)
    I found all of this on: http://www.curse.com/bukkit-plugins/minecraft
    Now im having troubles with multiverse-portals: i found on internet that i need another version, but i downloaded one updated in february?
    And my essentials, which i found on: https://hub.spigotmc.org/jenkins/job/Spigot-Essentials/ doesnt work...?

    Do all the plugins that work with 1.8 work with my server 1.8.7?

    This is my log file for essentials:

    [12:58:38] [Server thread/INFO]: Creating config from template: C:\Users\uporabnik\Desktop\Spigot server\plugins\Essentials\config.yml
    [12:58:38] [Server thread/ERROR]: java.lang.NoSuchMethodError: java.nio.CharBuffer.subSequence(II)Ljava/nio/CharBuffer;
    [12:58:38] [Server thread/ERROR]: Error occurred while enabling Essentials vTeamCity (Is it up to date?)
    java.lang.NullPointerException
    at com.earth2me.essentials.Essentials.onDisable(Essentials.java:348) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:323) ~[spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at com.earth2me.essentials.Essentials.handleCrash(Essentials.java:747) ~[?:?]
    at com.earth2me.essentials.Essentials.onEnable(Essentials.java:275) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:356) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:316) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:418) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:382) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:337) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:256) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:528) [spigot-1.8.7.jar:git-Spigot-f928e7a-994b2aa]
    at java.lang.Thread.run(Unknown Source) [?:1.6.0_18]
    [12:58:38] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
     
  3. I recommend starting from the first or updating all of your plugins and removing the old userdata before starting the server.
     
  4. Ok I had an odler version of Java...it works now :)

    Now i need a plugin for spawn...I actually have a UltimateHub, but it has some errors...all i ned from spawn plugin is that it will spawn mi in the same world everytime...

    I also installed Plotme plugin. I made new world and it looks fine. Now i need plugins for shop/economy (which is the best?) and I would like to make that it is availabble to buy a plot or just to rent it...how do i do that?
    Thank you very much,