Solved no perm for /vote

Discussion in 'Spigot Plugin Help' started by Qurp, Apr 14, 2017.

  1. so I have the plugins galistener and votifier, but whenever i do /vote, it says I have no permission!
    permission message: You do not have permission to execute this command!
    I even have the permission in my permissions ex config: upload_2017-4-14_8-43-45.png
    here are all of the plugins on my server if that helps: upload_2017-4-14_8-44-24.png
     
  2. bumpppppppppp
     
  3. well usually /vote doesn't have perm nodes. But with your plugins, you don't need "anti-enderman" or "warp signs" or "color signs" because you can do all that with essentials
     
    • Like Like x 1
  4. update: I have tried taking out every other plugin except votifier, galistener, and permissions ex to see if it was anothr plugin but I still did not have any permissions.
    here is a video demonstrating the problem:

    votifier version: votifier 1.9 ( for game versions CB 1.7.9-R0.2 and 1.6.2, I tried both ) and votifier 1.8
    galistener version: 1.3.1 and 1.3.2, I tried both
     
  5. remove the gallistern nodes from your config file
     
  6. hey um sorry im dumb
    how do you do that exactly? I dont know what you mean by galisten nodes (yes I know how to get into the config file)
    oh yeah and i forgot to mention that this is in the 1.8 game version
     
  7. like the pic you have, remove those galistener nodes from the owner group
     
  8. ohhh, okay, but which ones? all of them? Because even without those permissions it doesn't work
     
  9. is there anything else you did?
     
  10. nope, I just downloaded votifer and galistener and the vote command wouldn't work. Every other command for galistener works, just not vote.
     
  11. oh, I actually found an error:
    Code (Text):
    [15:56:40 WARN]: org.apache.commons.lang.UnhandledException: Plugin GAListener v1.3.2 generated an exception while executing task 141
            at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:56)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
    Caused by: java.lang.NoSuchMethodError: org.bukkit.Server._INVALID_getOnlinePlayers()[Lorg/bukkit/entity/Player;
            at com.swifteh.GAL.Metrics.postPlugin(Metrics.java:335)
            at com.swifteh.GAL.Metrics.access$4(Metrics.java:328)
            at com.swifteh.GAL.Metrics$1.run(Metrics.java:223)
            at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71)
            at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
            ... 3 more

    [15:56:40 INFO]: [GAListener] Loading queued votes
    [15:56:40 INFO]: [GAListener] Loaded 0 queued votes
     
  12. Well good thing you found it.
     
  13. well i mean I still havent fixed the problem lol
     
  14. i think that's the wrong version. your using 1.8 not 1.9 right?
     
  15. um I'm using minecraft 1.8, and ive used both votifier 1.8 and 1.9
     
  16. Replace the .jars you have with these ones and see if that works
     

    Attached Files:

  17. Nope, still no permission, thanks anyway.
     
  18. Disable pex and see if that works?
     
  19. nope, didnt work, thanks for the suggestion though
     
  20. Try updating GaListener to the latest version. Also, is your server in online mode?