No plugins install :(

Discussion in 'Spigot Plugin Help' started by Slumzy, Apr 2, 2020.

  1. I get the following quoted error below on console when downloading most new plugins...

    Before anyone suggests it... I have re-downloaded them, restarted the server numerous times, and even contacted the plugins developers to no avail.

    System Info:
    • Java 1.8 (Java HotSpot(TM) 64-Bit Server VM 25.191-b12)
    • Host: Linux 4.15.0-55-generic (amd64) 02.04 02:22:09
    • Minecraft Server version 1.15.2
    • Server is running Paper version git-Paper-155 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT)

    [​IMG]

    I've checked a number of places, and have spent most of my day trying to find the answer. Can anyone help me out please?

    If you need further info to help diagnose the problem - just ask! :)

    Thanks a bunch in advance!
     
  2. Code (Text):
    02.04 02:23:06 [Server] ERROR Could not load 'plugins/ProtocolLib.jar' in folder 'plugins'
    02.04 02:23:06 [Server] INFO org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
    You should remove ProtocolLib plugin
     
  3. Some plugins may require Plib to function so might not be able to do that ^, I do believe that Plib hasn't been fully updated to 1.15 yet (or atleast tested fully), I have however not encountered that issue with it, using version 4.5.0 on paper 1.15.2
     
    • Agree Agree x 1
  4. like is said, it has nothing to do with ProtocolLib in particular (I don’t believe), as this has happened to at least 4/5 plugins I’ve tried to download recently. I’m thinking it’s got something to do with either a) the hosting company, b) my machine (how I’m installing the plugins), as is did a fresh install of Windows recently and it seems to be an issue since it C) coincidentally a lot of plugins developers have decided to all create an error with their plugin that seems to just affect me and a very tiny handful of others.


    I’m thinking it’s A or B to be honest...
     
  5. can you send the plugin folder with only the *.jar files in it?
     
    • Like Like x 1
  6. Appreciate your interest in helping me mate! Did you want a snapshot of the directory, or did you want me to send the the folder zipped up?
     
  7. sent it zipped
     
    • Like Like x 1
  8. Why would you send someone your plugins folder lol, if you've got premium plugins inside it, I'd advise you not to do that
     
    • Informative Informative x 1
  9. I have, but I am removing the premium plugins first. Don't worry, I already thought of that.
     
  10. ah yes sorry for mentioning it. I didnt think i had to

    btw send only the ones that cause that error. yeah sorry i forgot to mention that too
     
    #10 astaspasta, Apr 2, 2020
    Last edited: Apr 2, 2020
  11. Zipped .jar only plugins folder here: https://drive.google.com/open?id=1MDsxiZHlhENBT2fvx6oody2h-MpL5GKh

    As above, I've removed my ownly premium plugin (CompatNoCheatPlus - MarkElf)
     
  12. No, it’s only recently it’s started doing this. ProtocolLib is the latest one to do it.

    The rest were installed previously and work fine.
     
  13. Mind installing just protocollib (without any other plugins), and checkin if it loads
     
    • Informative Informative x 1
  14. are you 100% you didnt put by accident an older version of these in your plugins folder? I started a 1.15.2 spigot server and got the same error but once i downloaded protocol lib again it worked fine
     
  15. Can you link me to where I can find the latest version? I tried downloading it from their spigot page. Thought that would have been the latest?

    Thanks in advance. Again, I appreciate your support.
     
  16. https://www.spigotmc.org/resources/protocollib.1997/
     
  17. Sounded like a good idea for testing purposes. Although same error persists.

    Does anyone know what file/program/jar is responsible for unpacking the jars in my server's file directory? Maybe it could be that?

    UPDATE: I just copied my plugins back into the folder after just putting ProtocolLib in to test.

    Now all of them (that were previously working), are all returning that error. Kill me now!

    So definitely something my end interfering. This is larger than downloading them from different browsers. Something on my machine is killing it.

    Any ideas?

    Am going to restart my computer and try again.
     
    #18 Slumzy, Apr 2, 2020
    Last edited: Apr 2, 2020
  18. Seems to me it could be a corrupted download, you sure it's downloading properly? (Also you can try extracting the .jar file, and checking if the plugin.yml file is correct)
     
  19. The hosting company just responded to my ticket with:

    How is this possible? At what point is my computer is intervening with the files and corrupting them? I'm going to try using Edge (Yuck!!!) as suppose to chrome to download it and see if it helps...