Non-Stop 20%-60% CPU usage?

Discussion in 'Performance Tweaking' started by flatbmx, Mar 27, 2013.

  1. Recently after updating to #729 i noticed a thread running always around %20-%60 but all other cores are running at %1. Before this never happened and cpu usage was at %1 total for the java process. Now its at #5 atlteast. I looked over this timings and whats the worst problem, Entitys in plotworld or the full server tick?

    http://www.aikar.co/timings.php?url=5652197

    Also what is processed in doTickRest for worlds?
     
  2. I got the same problem i think, these are my timings:
    http://aikar.co/timings.php?url=5671247

    And my cpu is 10-15% higher then normal.

    World Guard report:
    http://pastebin.com/ujY5XzMf

    Plugins (56): BukkitCompat, BuyMagic, Buycraft, Vault, pvpstats, Multiverse-Core, dynmap, Register, Votifier, mcMMO, FoundDiamonds, Lift, Jobs, Fe, WorldEdit, JCVaultListener, Towny, MotdManager, Multiverse-NetherPortals, War, LogBlockQuestioner, PermissionsEx, LogBlock, Questioner, LWC, WorldGuard, HeadDrops, boosCooldowns, mChatSuite, HeroicDeathPlus, Cenotaph, BKCommonLib, Simple Player List, TheEndAgain, GiveTo, MyWarp, ManySmallTweaks, Essentials, VoteSQL, WorldBorder, Multiverse-Portals, MCBans, Dynmap-WorldGuard, MagicSpells, ChestShop, MobArena, EssentialsXMPP, TownyChat, ChatManager, EssentialsProtect, EssentialsSpawn, Dynmap-Essentials, EssentialsGeoIP, EssentialsAntiBuild, MagicSpellsShop, Dynmap-Towny
     
  3. I think my server is suffering similar problems, did any of you find a solution?