"none" being added to the end of chat messages.

Discussion in 'Spigot Plugin Help' started by epicc, Feb 13, 2020.

  1. After setting up buycraft on my server and deopping myself to try it out, I found that every time I put a message in chat, there would be a "none" after it. I then tried opping myself and the none dissapeared.
    Deopped: 2020-02-13_21.26.16.png
    Opped: 2020-02-13_21.26.05.png
    Here is a list of my plugins:
    LuckPerms, LeakParkour, ColoredSigns, ItemToCommand, VoidWorld, PerWorldPlugins, PlugMan, BuycraftX, FastAsyncWorldEdit, Sudo, CrispyDisguise, ViaVersion, Vault, WorldEdit, Essentials, CreateYourOwnMenus, WorldGuard, ProtocolLib, Citizens, ASkyBlock, EssentialsChat, SuperVanish, WorldGuardExtraFlags, HolographicDisplays, Multiverse-Core, CitizensCMD, Multiverse-Inventories, Multiverse-Portals, HubBasics

    Please help.
     
  2. I would advise you to check the various config of plugins that use chat. For example EssentialsChat or MultiverseCore
     
  3. It only appears to happen in the hub world. Example: 2020-02-13_22.04.13.png
     
  4. Check HubBasics
     
  5. I looked through the Multiverse, Essentials and HubBasics config and Ctrl-F'ed for "none" but I couldn't find anything.
    I looked in
    HubBasics: config.yml & messages.yml
    Essentials: config.yml
    Multiverse: config.yml & worlds.yml
     
  6. Check out the plugins you put in for the various worlds with PerWorldPlugins
     
  7. This is my PerWorldPlugins config

    exempt-login-events: true
    check-for-updates: true
    blocked-msg: '&c[Error] This command cannot be performed in this world.'
    limit:
    ColoredSigns: []
    FastAsyncWorldEdit: []
    PermissionsEx: []
    CrispyDisguise: []
    ViaVersion: []
    Vault: []
    ProtocolLib: []
    WorldEdit: []
    Essentials: []
    EssentialsChat: []
    SuperVanish:
    - world
    - world_nether
    - world_end
    - bedwars
    Multiverse-Core: []
    Multiverse-Inventories: []
    WorldGuard: []
    LeakParkour: []
    HubBasics: []
    VoidWorld: []
    Citizens: []
    CitizensCMD: []
    Multiverse-Portals: []
    CreateYourOwnMenus: []
    HolographicDisplays: []
    JustWorlds: []
    MultiWorld: []
    PlugMan: []
    LuckPerms: []
    ASkyBlock:
    - sbhub
    - ASkyBlock
    - ASkyBlock_nether
    WorldGuardExtraFlags: []
    Sudo: []
    ItemToCommand: []
    BuycraftX: []
     
  8. Try to use LuckPerms' verbose feature and send any message - it should show you some permissions that were required for chat.
    I think it's MultiVerse, but not sure enough. Anyway try to disable "prefixchat" in the config - pretty sure no one will die because of this x)
     
  9. Thanks, I will try the Multiverse thing, but what do you mean by "verbose feature"?
     
  10. /lp verbose