1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Not specify an api-version. Spigot 1.14.4

Discussion in 'Bugs & Feature Requests' started by zFeniiks, Feb 11, 2020.

  1. can anybody help me? I migrated from host this week, before migrating there was no error in the console, now it is giving these api errors and I don't know how to resolve them. Discord zFeniks#5934


    -=-=-=-=-=-=-
    11.02 11:10:10 [Server] Server thread/WARN Plugin nLogin v6.2 does not specify an api-version.
    11.02 11:10:10 [Server] Server thread/WARN Plugin NickUC-Updater v1.4 does not specify an api-version.
    11.02 11:10:10 [Server] Server thread/WARN Plugin ReisAntibot v2.0.46-Legacy-WithVerify does not specify an api-version.
    11.02 11:10:10 [Server] Server thread/WARN Plugin MTDiscordLogin v1.9 does not specify an api-version.
    11.02 11:10:10 [Server] Server thread/WARN Plugin JDA v0.1.4 does not specify an api-version.
    11.02 11:10:10 [Server] Server thread/WARN Plugin AntiOP v2.9 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin Multiverse-Core v2.5-b719 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin DiscordBotAPI v3.0 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin MVdWPlaceholderAPI v3.0.1 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin ServerListPlus v3.4.8 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin GemsEconomy v4.8.3 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin Marriage v2.0.19 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin Holograms v2.11 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin UltraCustomizerPlus v1.4 does not specify an api-version.
    11.02 11:10:12 [Server] Server thread/WARN Plugin JH_AntiCrashExploits v1.0.4 does not specify an api-version.
    -=-=-=-=-=-
     
  2. if you want people to DM you on discord then un-check open
     
  3. That is no error. Theses plugins are not updated to 1.13+. So Spigot provides a legacy layer to support them.
     
  4. @ysl3000 ok, but even then this problem was not happening to me, it started a short time ago and some plugins are having a problem and are not working, being what they used to work.
     
  5. What plugins aren’t working
    This isn’t a bug too
     
  6. @lokka30 almost everyone is with this
     
  7. Have you updated them all
     
  8. 1.02 11:10:12 [Server] Server thread/WARN Plugin Multiverse-Core v2.5-b719 does not specify an api-version.

    vs.
    Multiverse-Core-4.1.1-SNAPSHOT.jar


    He is running outdated plugins.

    @zFeniiks You need to update the plugins. You expect that plugins run that aren't updated by you?
     
  9. Let me turn the dial 6 years ahead, my plugins will work without a problem :LOL:
     
  10. Some do, others don't. ⅔ of mine will not work in 1.16 without adaption. But these are API's. :D
     
  11. @ysl3000 All of my plug-ins are available !!!!
     
  12. I was mentioning that swapping the server version without updating plugins is silly
    Also how did you test for 1.16
     
  13. Magic. No just the knowledge. My API's abstracting NMS stuff so I need to implement the 1.16.x stuff when Mojang/Spigot releases its first release build. Mappings changes.
     
  14. Then update them....

    Or do you expect them to work, when they get loaded and are green?