1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Crash Odd Crash

Discussion in 'Bugs & Feature Requests' started by SpaZMonKeY777, Feb 7, 2013.

  1. SpaZMonKeY777

    Wiki Team

    md_5
    So starting last night been having this weird server crash issue. Server can be running perfectly fine, and then all of a sudden lock up, read time out, and become unresponsive.

    Here are the reports:
    Spigot Report: http://pastebin.com/GEdDrXTp
    Crash-Report: http://pastebin.com/USF45k9b

    Sometimes it will stay up for 2 hours before a crash, and this last crash and report it was only up for like 5 minutes. Very odd...
     
  2. SpaZMonKeY777

    Wiki Team

    So it was up all day yesterday, thought I had it fixed, but it crashed again overnight last night:

    http://pastebin.com/7PvjiScY

    I'm at my wits end here.
     
  3. SpaZMonKeY777

    Wiki Team

    Still looking for a solution to my issue :(

    Don't know if this is allowed, but I am willing to offer a nice reward to anyone who can help us figure this issue out. I can supply and all information needed, but my community is getting a bit frustrated by these random timeout crashes.

    If offering a bounty for my solution is not allowed here, then please delete. Otherwise, I am open to solutions. Thanks!
     
  4. md_5

    Administrator Developer

    This is that report that is physically impossible without some plugin doing crazy shit that is guaranteed to crash the server.
     
  5. SpaZMonKeY777

    Wiki Team

    This is why I am willing to hire help. I don't know what steps to take to start tackling this problem. Just disabling plugins to see what works and what doesn't isn't very viable. I tried it, but the crashes are too random. We had 6 timeouts overnight within 6-8 hours, and then the next day it stayed online for 13 hours before it timed out.

    Mind you, this is with a full server (80+) and 20 TPS. Memory usage is perfect, and our skyblock server we run on the same machine is not affected. When it happens, everyone gets kicked with a basic Read.Timedout error and the console gives NO errors at all, it just starts popping Read Timed Out every minute until I manually kill the process.

    Even just utilities or programs that could help me narrow down the problem. I just want to solve this problem, and I am willing to do whatever it takes. I just need guidance :)
     
  6. Would it be silly of me to ask you if all of your plugins are infact up-to-date?

    Perhaps you could show us the list of plugins?

    Back in the days I had this issue.
    I tried reverting the LWC and Worldguard database back to SQL instead of MySQL, but I'm not sure how many regions/protections you have, if any at all.
    Anyways that fixed my issues.
     
  7. SpaZMonKeY777

    Wiki Team

    Im at work at the moment, but I will post a list later. I did add LWC to MySQL a couple months ago, maybe I will revert back to sqlite. And I am very OCD about plugin updates and changes. My wife and I check for updates multiple times a day and test dev builds often.

    With that said, we have a few plugins that are very lightweight and important to us, but are out of date. They never throw any errors and never showed issues before. I will post a list when I get a chance along with which ones have not been updated.
     
  8. Yeah well it depends on the plugin and what it does.
    Some plugins don't really need updates.

    Btw you can revert to SQL fairly easily, no reload/restart required, and you can revert back to MySQL after if you want aswell.
     
  9. SpaZMonKeY777

    Wiki Team

    Ya I will probably try converting LWC database back over, my SSD runs very well anyway, not much need for MySQL.

    Anywho, here is a list of all the plugins we are currently using:
    Hope this information helps. Not sure how to change LWC database on the fly, but I will change it in the config and do a restart soon to convert it and see how it runs. An obvious worry is our world has corrupted chunks, but I am not sure how to check that or confirm that. Our world is very large lol.

    Thanks again for the help so far, really means a lot to get some help :)
     
    #9 SpaZMonKeY777, Feb 18, 2013
    Last edited: Feb 18, 2013
  10. LWC conversion on the fly: `/lwc setup database NewType
    Replace "newtype" with the database type of course :)

    Btw correct me if I am wrong, but isn't "VanishNoPacket" useless due the Essentials /vanish ?

    Multiverse is working just fine on my Server (have use the same add-ons).
    I am however using dev builds, not sure if you are.

    Oh and Disguisecraft has caused me trouble before.
    Perhaps you want to disable that to test. I am sure your donators won't have an issue with it being unavailable for today :)
     
  11. SpaZMonKeY777

    Wiki Team

    I updated the plugin list above, as I forgot to mark a bunch I tested. And we use VanishNoPacket because it had some extra features and ability to fine tune vanishing for our Admins.

    Also, I tried converting our LWC database, and got this error in console: http://pastebin.com/aSDteGJT And after looking at the sqlite database, it removed a ton of recent locks, almost cutting the db size in half. So I managed to revert it back to mysql for the time being. Should I ticket that error to LWC?

    On a side note, I thought I found the solution last night. Turned out even though I downloaded the most recent version of Essentials, the server was running a slightly old version. So I updated, and the server didn't crash at all last night. On a bad note, it locked up this morning, right before I was going to do a restart. So it lasted 8 hours.

    I'll continue to try disabling certain plugins and hopefully narrow it down. Wondering if LWC is causing an issue though, as we have a very large database (65Mb).
     
  12. Jigsaw

    Supporter

    My LWC database (MySQL) is 112.2Mb so i don't think that is an issue.
     
  13. Well if you're serious about trying that I do recommend you to ask the dev of the plugin.
    I can't tell you why it's not working sorry :(
    - 65mb is a fairly large database though.
     
  14. SpaZMonKeY777

    Wiki Team

    Well over the last couple days, it seems to be running better, but still crashing once or twice a day. Last night it crashed and I actually have a thread dump in the console: http://pastebin.com/eFEFJ3Qa

    Maybe someone can make sense of it. I see GroupManager tossed an error when it stopped the server.
     
  15. There's a lot of "netty" errors.
    Not sure if those are really errors causing the crash... Might want to try a build without netty?
     
  16. md_5

    Administrator Developer

    First rule of life, just because it appears there doesn't mean its even relevant. There is also JLine in there, but its not relevant.
    Start my disabling some of your less known plugins.
     
  17. I just started experiencing this problem today for some reason. Just updated to Spigot Jenkins Build ##551 and I started noticing it crashes almost every 10-15 minutes, sometimes more, sometimes less. I've tried removing all of the plugins that I've updated since I started noticing the crashes, but it still crashes (and I'm only running about 38 plugins which are all pretty common and have dev build links).

    I've even tried running the server while I was the only one on, all I did was fly around for about 5 or 10 minutes and it eventually crashed w/o any errors in console, just gave my client the time out error.

    I will try to run a local server w/ nothing but Spigot installed to see if I still have the problem

    EDIT: Not experiencing any crashes w/ Craftbukkit Dev Build #2631 w/ same setup.
     
    #17 nickbbeezy, Feb 21, 2013
    Last edited: Feb 21, 2013
    • Agree Agree x 1
  18. I have the same problem that nickbbeezy has. :/
     
  19. md_5

    Administrator Developer

    You mean exactly this error:
    http://pastebin.com/USF45k9b
    If so, paste it to me, I seriously doubt you have that error.
     
  20. md_5

    Administrator Developer

    How is that anything to do with this thread?