Solved Odd Server Version Error

Discussion in 'Spigot Plugin Development' started by Avenged_, Apr 6, 2017.

  1. Hello everyone,
    I'm currently creating a plugin, and for some reason I can't figure out, it won't load on one of my spigot servers. I'm running a bungeecord server setup, and it runs fine on every server except for my hub. The commands are able to work, and the plugin shows up in /plugins. The only thing not working properly are the listeners. I've tried matching the server versions (1.8.8), and even copying the jar from a working server to the hub, and still nothing.

    Not sure if you guys have ever crossed upon an issue like this, it would be great if someone could tell me the solution.

    Thanks,
    Avenged

    EDIT:
    Just figured this out! It happened to be a problem with the way my packages were setup. I believe some packages had similar names which was causing it to not work properly... Hopefully this helps anyone experiencing the same issues!
     
    #1 Avenged_, Apr 6, 2017
    Last edited: Apr 6, 2017