OnlyProxyJoin & IPFowarding?

Discussion in 'Spigot Help' started by MCraftGamer35, Jun 2, 2015.

  1. I noticed that when I have IPFowarding on OnlyProxyJoin doesn't work. Is there any way to fix this because my server got greifed and I am furious, just looking for a resolution.
     
  2. Are you using BungeeCord? If so, you can set "BungeeCord" to true in your spigot.yml file. That should only allow players to join via the proxy server.
     
  3. @Yupie we already had that set, and it doesn't fix the issue.

    See that basically means someone can setup a proxy and join directly to those servers on it and have full access.

    But yes, BungeeCord is true. It doesn't fix anything.
     
  4. Hmm, I had the same issue a few months ago. Let me remember what I did to fix it. I think you should take a look at the bottom of your Bungee config.yml. I forgot the name of that setting but I remember changing it to fix this issue.
     
  5. IPFowarding or Online Mode? @Yupie

    Let me mention we are in online mode also.
     
  6. @Yupie it is currently on, should it be off?
     
  7. @Yupie and how does the bungee config have anything to do with players on seperate servers force opping on my account?
     
  8. Weren't players able to connect via the seperate servers' IP? I thought that was the issue, might have misread your question then.
    I thought they logged on via an ops account because online-mode should be set to false on seperate servers.
     
  9. @Yupie players are joining directly onto our servers connected with bungee cord joining on my account, yet when I connect to the direct IP it doesn't let me.
     
  10. @MCraftGamer35 Do you want players to directly connect to your seperate servers?
     
  11. @MCraftGamer35 You should set use-bungeecord to true in each spigot.yml of your seperate servers, and set the connection-throttle to -1 on each bukkit.yml. You also need to set online-mode to false on each seperate server (bungeecord will handle the online mode). Then you also need to set online-mode and ip-forwarding in bungee config to true.

    That did the trick for me. It's very unsafe to give away seperate IP's for each server. I have done it before and haven't found an exact solution for that. But since I did all the above, it has never happened to me.

    At last resort you should ask your host for an IP change. (I know that Beastnode does this, not sure about other hosts).
     
  12. Those were the settings already set. @Yupie
     
  13. An IP change would do nothing either because they can ping the domain and get the IP easily. @Yupie
     
  14. Hmm, well I don't think I can help you further then. I've had this issue before aswell, but I just changed my IP. You could try that aswell, but I don't have a solution for your problem right now, sorry.