op [username] in console gives no permissions (1.14)

Discussion in 'Server & Community Management' started by zech9, May 14, 2019 at 1:28 AM.

  1. I would like to start off with the fact that this isn't the first server I've run, and that I have never had this issue. The server I am running works and others can join from a different connection, but attempting to use commands in the console does not affect the server at all. I used op [username] in the console (no I did not do /op) and it said "Made [username] a server operator". When I attempted to use commands in the server, it said I did not have the permission. Another important piece of info is that when I attempted gamemode creative [username] it said "No player was found". There seems to be a disconnect between the commands in the console and what happens in game. I also checked in "ops.json" and it says
    [
    {
    "uuid": "95b2c591-1e69-41de-84ba-a325d8c508ad",
    "name": "Username",
    "level": 4,
    "bypassesPlayerLimit": false
    },
    {
    "uuid": "d83a8b95-ecc7-4528-894c-efdeb8bb4bc6",
    "name": "FriendUsername",
    "level": 4,
    "bypassesPlayerLimit": true
    }
    ]
    Edit: I also have no plugins. I have been able to have operator abilities without plugins before so I don't think that is the issue.
     
  2. Did you build your spigot build yourself or did you download it somewhere?
    Is this 1.14's latest --rev 1.14 build, or an outdated one? (type ver and check in console)
    Are you running your Spigot server in offline mode?
    Are you in bungee perhaps? You type it in one server, but the player is elsewhere?
     
  3. I downloaded the jar file off of .org and went through the same process I have done for past servers, following the eula, creating the run.bat file, loading the world, op'ing myself and the only thing that went wrong is that I don't actually have op. I did not download bungee but if it comes with that download automatically that may be the issue. I am not sure if I am in offline mode, but judging from the fact that my friend living in a different state was able to join I believe it is on online mode. How can I check to see if it is in online mode?
    When I type ver in the console it tells me "This server is running CraftBukkit version git-Spigot-4d24e36-5193f76 (MC: 1.14) (Implementing API version 1.14-R0.1-SNAPSHOT)"
    Thank you for replying so quickly
    Edit: I just looked in the server.properties file and it says online-mode=true. Also if I attempt to do the command again it says "Nothing changed. The player is already an operator."
     
    #3 zech9, May 14, 2019 at 9:38 PM
    Last edited by a moderator: May 19, 2019 at 3:16 AM
  4. DON'T use third party download sites, the JAR can contain malicious code. You should ALWAYS build Spigot with BuildTools.
     
    • Agree Agree x 1
  5. Go
    Good to know. I will try from there and see if the problem persists
     
  6. Yeah, get buildtools from spigotmc, then use that to buld your own spigot jar.
    This way you know it's the actually latest version (especially when you want 1.13.2 and use --rev 1.13.2 in the startup of java -jar.. etc) and doesn't come with ... other things.
     
  7. OK so now it says
    **** FAILED TO BIND TO PORT!
    [15:13:22] [Server thread/WARN]: The exception was: java.net.BindException: Address already in use: bind
    [15:13:22] [Server thread/WARN]: Perhaps a server is already running on that port?
    And then when i press a key to continue it crashes.
     
  8. "Address already in use: bind"

    Another java applet is already running, probably still, binding to that port.

    Stop that one first, so it unbinds, and then start the one you want to start, so it can bind to it.
     
  9. I had tried that before and I found nothing running with Java so I just went into server.properties and changed the port number. I tried what you said and it worked exactly as intended. I guess changing the port number created some kind of disconnect. Thank you!
     
  10. You cannot change port bind while the server is running.

    on linux you can : ps aux | grep "java", to see all active javas and theirs procs, tohelp you find ghosted instances and such
     

Share This Page