Outdated Spigot Version + Java Runtime

Discussion in 'Spigot Help' started by Loxo, Jun 9, 2018.

  1. (For everyone: Im from Germany and my english is not the best. So I hope you can understand me.)

    Hello there,

    currently Im creating a localhost server on my pc and there is one message the is doing some problems:

    *** Error, this build is outdated ***
    *** Please download a new build as per instructions from https://www.spigotmc.org/ ***
    *** Server will start in 15 seconds ***
    ------------------------
    So I tried to fix it with BuildTools. I did everything like in the video but some files werent created.
    Screenshot: http://prntscr.com/jszbln
    As you can see the .jar files are missing and I dont know why. I tried it several times and it still doesnt work.
    Note: The server is running perfect, but the message shouldnt be there as I heard.


    Now to my second problem:

    Some days ago I started to learn Java and to make some plugins for the server. But everytime I start the server with my selfmade test plugin the following message is comming in the console:

    [18:09:22 ERROR]: Could not load 'plugins\1.Versuch.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/loxo/lobby/main/Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot_server.jar:git-Spigot-f950f8e-0a81101] at org.bukkit.craftbukkit.v1_11_R1.CraftServer.loadPlugins(CraftServer.java:300) [spigot_server.jar:git-Spigot-f950f8e-0a81101] at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:204) [spigot_server.jar:git-Spigot-f950f8e-0a81101] at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:542) [spigot_server.jar:git-Spigot-f950f8e-0a81101] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_25] Caused by: java.lang.UnsupportedClassVersionError: de/loxo/lobby/main/Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0 at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_25] at java.lang.ClassLoader.defineClass(ClassLoader.java:760) ~[?:1.8.0_25] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_25] at java.net.URLClassLoader.defineClass(URLClassLoader.java:455) ~[?:1.8.0_25] at java.net.URLClassLoader.access$100(URLClassLoader.java:73) ~[?:1.8.0_25] at java.net.URLClassLoader$1.run(URLClassLoader.java:367) ~[?:1.8.0_25] at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.8.0_25] at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_25] at java.net.URLClassLoader.findClass(URLClassLoader.java:360) ~[?:1.8.0_25] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_25] at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_25] at java.lang.Class.forName0(Native Method) ~[?:1.8.0_25] at java.lang.Class.forName(Class.java:344) ~[?:1.8.0_25] at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot_server.jar:git-Spigot-f950f8e-0a81101] ... 6 more

    ---------------------------------

    If anyone knows something please let me know.
    Have a nice day!
    ~Max
     
  2. #2 ysl3000, Jun 9, 2018
    Last edited: Jun 9, 2018
  3. The plugin has been compiled for Java 9, you seem to be having Java 8.
     
  4. To the second answer:
    As I said, I did. Did you looked at my screenshot? The .jar files werent created. Do you know why?
     
  5. Clean everything in the folder except the BuildTools.jar
     
  6. Still the .jar are missing...
     
  7. Thank you. Now it is fixed.