Packet 0x08 and 0x10 Exploit

Discussion in 'Spigot Help' started by Stefan15ist, May 7, 2015.

  1. So I think my server was attacked today, someone made that malicious client, and there is a fix for 1.8.4, but is there any fix for spigot #1649?, thanks

    Note: if you don't know what I'm talking about then don't bother replying
     
  2. No and there will never be an official fix.
     
  3. What is that exacly a fix to the bug? and is it exacly 1649?
     
  4. Just use it. You can find the source in the Spigot hub.
     
  5. PhanaticD

    Patron

    no it is not exactly, no one uses build 1649. It works fine (better) though dont worry
     
  6. I use it because it supports both 1.7 and 1.8
     
  7. does anyone know where I can find the code that fixes it so I can implement into the jar myself?
     
  8. PhanaticD

    Patron

    even so, people used the protocol patch file updates when that was relevant. Or should have been anyway..
     
  9. May I ask why you care about 1.7 clients? 1.8 has been out for what almost a year now and most things work with it. Just curious, hate to be off topic.
     
  10. because more than 50% of my users apparently lag with 1.8, and pvp is also not that good
     
  11. Update to the latest Spigot and install ProtocolSupport.

    Now you can reach 1.5.2+ clients, and stay up to date with bugfixes. Stop using out of date server software.
     
    • Agree Agree x 2
    • Winner Winner x 1
  12. what o_O
     
  13. Read my post, then read it again. If you still don't understand, read it again. Make sure you read my post and don't forget to read my post.

    I don't know what you don't understand, a response with more than "what" is appreciated.
     
    • Funny Funny x 2
    • Like Like x 1
  14. 1.5.2 is a lot
     
  15. Yes, and it supports it. Why bother doing all the extra work when the plugin does all the work.
     
  16. doesn't seem very stable yet, there are people with a few errors
     
  17. We're using it, it works just fine. I've tested it across 1.7.2, 1.7.4, 1.7.10 and 1.8+, no problems.
     
  18. they say it doesn't support bungeecord
     
  19. BungeeCord does not support pre 1.7 clients. Do you really need to support every clients since 2012? It works with 1.7 and 1.8+, as you originally requested.
     
    • Agree Agree x 1