[Paying 10$] Help on Plugin :'( [Essentials Plugin]

Discussion in 'Systems Administration' started by Anyome, Jun 1, 2015.

  1. Hello guys!
    I bought my own dedicated server from OVH, and want to go to the next level and host my own Minecraft Server.
    The problem is that my plugin: Essentials don't want to works anymore... but it was working before in my game host server.

    I think it's coming from my FTP permissions, i already tried theses commands:
    chmod 777 /home/minecraft/server
    chmod 777 /home/minecraft/server/plugins

    But i still have the same problem =(

    When i run my server using this:
    java -Xmx2048M -Xms1024M -jar spigot_1.8_R0.1_SNAPSHOT.jar nogui

    My Console Log:

    [01:29:14 INFO]: Preparing start region for level 2 (Seed: 8162906296079493353)
    [01:29:14 INFO]: [Essentials] Enabling Essentials vTeamCity
    [01:29:14 INFO]: Bukkit version format changed. Version not checked.
    [01:29:14 INFO]: git-Spigot-c3c767f-33d5de3 (MC: 1.8)
    [01:29:14 INFO]: 1.8-R0.1-SNAPSHOT
    [01:29:14 ERROR]: java.lang.NoSuchMethodError: java.nio.CharBuffer.subSequence(II)Ljava/nio/CharBuffer;
    [01:29:14 ERROR]: Error occurred while enabling Essentials vTeamCity (Is it up to date?)
    java.lang.NullPointerException
    at com.earth2me.essentials.Essentials.onDisable(Essentials.java:348) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:323) ~[spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at com.earth2me.essentials.Essentials.handleCrash(Essentials.java:747) ~[?:?]
    at com.earth2me.essentials.Essentials.onEnable(Essentials.java:275) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugin(CraftServer.java:356) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.enablePlugins(CraftServer.java:316) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.q(MinecraftServer.java:402) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.k(MinecraftServer.java:370) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.a(MinecraftServer.java:325) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:211) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot_1.8_R0.1_SNAPSHOT.jar:git-Spigot-c3c767f-33d5de3]
    at java.lang.Thread.run(Thread.java:701) [?:1.6.0_34]
    [01:29:14 INFO]: [EssentialsChat] Enabling EssentialsChat vTeamCity
    [01:29:14 INFO]: [EssentialsProtect] Enabling EssentialsProtect vTeamCity

    _____________

    Does anyone know where this is coming from? i already tried all the Spigot versions, and Essentials versions.
    I'm using this version of essentials: https://hub.spigotmc.org/jenkins/job/Spigot-Essentials/

    I can pay 10$ on Paypal to the person who could help me to fix this problem, or have experience on Debian.
     
  2. There is something not up to date. Try updating Spigot. I hope this is your solution ;)
     
  3. Hey bro :)
    Thanks for your fast answer.

    I already tried the lastest version of Spigot before trying this old one.

    Do you have Skype or Steam so we can talk to each others?
    Thank you.
     
  4. skype: puddanator
     
  5. Are you sure are you using the lastest version of Spigot?
    Because on your run script you are using "spigot_1.8_R0.1_SNAPSHOT" while the lastest version it's "spigot-1.8.6-R0.1-SNAPSHOT"
    Maybe you are launching the wrong jar
     
  6. If you wanted to I could have a look at it, I think I may know what the issue is because my friend may have had it on his kimsufi (owned by OVH) server.
     
  7. Also, are you running Mine-OS, because I have experience setting that up and most likely know the issue (i guessed you were because mine OS runs on top of debian)
     
  8. This issue is over 20 days old...
     
    • Agree Agree x 1
  9. Are you running the latest spigot and essentials? If not, make sure your running the SNAPSHOT Essentials for Spigot 1.8 :) Might be the problem!
     
  10.  
  11. Try renaming the jar file from the screenshot to just spigot.jar. :)
     
    • Optimistic Optimistic x 1
  12. Are you sure your running the essentials snapshot file?
     
  13. Nah, his server is already running on Java8.
     
  14. Holy crap. Why are people still replying here. I already said, this issue has most likely been resolved. Stop replying to a 25 day old thread just because he offers money.