PAYING FOR FIX Can not connect to hubs. (ERROR: java io.netty.channel.unix.Errors$NativeIOException)

Discussion in 'BungeeCord Help' started by Quadro, Jun 9, 2016.

  1. I've had this error whilst botting my server (stress tests).
    Whenever I try to join my hubs, it won't let me, and gives me this error:
    java io.netty.channel.unix.Errors$NativeIOException

    I've tried deleting all bungee plugins, switching to Waterfall, doing everything, and it won't work.
    My bungeecord plugins are: TCPShield (my ddos prot provider), MoveMeNow, RedisBungee, and HubMagic.

    My bungeecord configuration: https://hcartels.org/config.yml

    My release is next week, and I would really like a fix.
     
  2. I'll pay for a fix.
     
  3. Add me on skype **** checked your pm
     
  4. Have you tried clearing all of your hub plugins? Set another server to default and attempt to join. Isolate whether or not it is your hubs or Bungeecord itself.
     
  5. I've tried removing all plugins. Seems to be a bungee issue
     
  6. I'm guessing you don't have the latest Bungeecord; try updating it to the latest stable build. Additionally it seems like the connection is being made on 127.0.0.1:21111 ; are you connecting using localhost? If so try the external ip; if it gives out the same error. If it does; make sure in the bungeecord config.yml the host is localhost or the external ip.
     
    • Like Like x 1
  7. I run all servers off the same box.
     
  8. Alright; do what i told you above.
     
    • Like Like x 1
  9. I am more than likely this is my home connection bottlenecking..
     
  10. but you've yet your connection-thorttle to -1 in your bukkit.yml right?
     
  11. Yeah..


    It's a new error now. http://prntscr.com/bfkefv
     
  12. JamesJ

    Supporter

    What are you binding to on your hubs? (in your server.properties)
     
  13. 127.0.0.1, the same thing that's in the bungee config. I run all my servers off of the same machine.
     
  14. JamesJ

    Supporter

    Show us the result of iptables -F -n
     
  15. can you attach a latest.log a proxy.log & the spigot,bukkit.ymls, cause I/We can look its bungee or spigot, cause I stuck at this point
     
  16. It's bungeecord, I am for sure..
    Also, this happens when I log off? http://prntscr.com/bflk60
     
  17. JamesJ

    Supporter