1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug People and animals lagging around [possible fix]

Discussion in 'Bugs & Feature Requests' started by dolan, May 4, 2013.

  1. As alex_markey posted here: http://www.spigotmc.org/threads/packets-slowed-down-in-latest-builds-causing-lag.1926/
    This is what the lag looks like, it wasn't happening to me on build #735, but it has been happening to me on the late 1.5.1 builds and on the latest 1.5.2 builds #834-#844.

    Here's a short video of the lag (ignore the start text):

    You can see how only animals and players lag but there is no block lag. Also that server had no plugins and the server specs are 64 GB DDR3 ECC, Intel Xeon E5-1650, 2x 120GB SSD and 1GB Uplink. When we switched up the jar to the #735 this lag stopped immediately.

    I'm not sure why you don't see this lag, but as you said in the top link thread:
    This lag is happening to people in america, united kingdom, australia, new zealand, asia, other european countries that do not speak english fluently, from what I've asked people in my server. So this cant be from internet speeds.

    It would be nice if you could just 1 release on 1.5.2 with the 10ms delay back to normal as in build #735 on 1.5.1 and if the lag does stop that would be greatly appreciated to have all builds on that ms delay.

    Thanks for reading this far.
    Kind regards, dolan.
     
    #1 dolan, May 4, 2013
    Last edited: May 4, 2013
    • Agree Agree x 2
  2. This is exactly what is happening on my server, althought not that major.
    I also agree that realeasing one Dev build with the normal delay back to see if that fixes it would be great =)
     
    • Agree Agree x 2
  3. Using build #844
    Players on my server are getting big lag spikes every few minutes.
     
    • Agree Agree x 2
  4. It's true.
    On my server exactly the same problem is :(
    //Build 844
     
    • Agree Agree x 1
  5. md_5

    Administrator Developer

    Its since been reduced to 5ms.
    To put this in perspective, it's basically as if the server is running at 19.9 tps all the time. If this is what you perceive to be an issue, there are bigger problems out there.
     
    • Disagree Disagree x 1
  6. looking forward to the new update to have 5ms, so this lag has stopped this is a big issue for and a lot of servers.
     
  7. joehot200

    Supporter

    md_5, could you please just add a option in the bukkit.yml to be able to change it?
     
    • Agree Agree x 1
  8. that would be cool
     
    • Like Like x 1
  9. Agreed, would be very useful and would end this discussion
     
    • Agree Agree x 1