1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug People logging in or teleporting into blocks

Discussion in 'Bugs & Feature Requests' started by FuRiouSOne, Jan 8, 2013.

  1. After updating to 383 build im getting reports people are teleporting into blocks or even logging in into block and suffocating. They are unable to do /spawn or /home as the damage taken breaks the teleport cool down, also unable to break the block as its protected.

    Previous build that didnt have these reports from players was 365. No other plugin was updated or changed when updating spigot to 383. Please look into this and find a solution, thanks.
     
  2. I have disabled suffocating within essentials till this is worked out. Unsure what is causing this or able to reproduce it even if i try to make a solid cube at one of my /homes. I have noticed a difference when logging in after updating to build 383, i tend to bounce upwards upon logging into the server even have fell through a floor upon log in if there was an open room underneath.
     
  3. md_5

    Administrator Developer

    What is the value of use exact login location in bukkit.yml?
     
  4. Already checked that and its use-exact-login-location: false
     
  5. Take it no one else is having this problem? Curious if it has something to do with how chunks are loaded and unloaded with the new NibbleArray ?
     
  6. I'm also having this problem intermittently. Not just on login, but after TPing using Essentials and Residence as well. The workaround for most users is to just set the TP point on top of a few blocks and then remove the blocks. Seems like the players just fall a few blocks before the chunk loads resulting in them being inside the floor. (SSD, 1gbit, 20TPS)
     
  7. Yeah were seeing this every once in a while as-well. Spigot 386. Use Exact-Login is false...
     
  8. Updated to 387 and now players are randomly dying? One player fell off a high platform falling to water and died as he hit the water? tried reproducing it and landed in water safely second and third time. Another player logged in after a restart and died at random as well in a mine shaft he was in before restart.
     
  9. Puremin0rez

    Moderator

    Same problem, exact login false
     
  10. md_5

    Administrator Developer

    From what Amaranth told me, vanilla now has use exact login always set to true, so yeah.
     
  11. Puremin0rez

    Moderator

    Interesting... I guess i'll try it out
     
  12. I also see this message every time the server starts:
    13:13:56 [INFO] evildragon998 went up in flames
    The player doesn't die(because he's not online maybe?)
     
  13. This isnt true info or not very accurate. Try setting a home then building a 5x5 solid block where your home is then teleport to your home, the game will push you out of the 5x5 solid block safely if use-exact-location: false but place you inside the 5x5 solid blocks if use-exact-location: true.

    What is happening is when players teleport to an area where chunks need to be loaded the player will fall through the world (blocks) till the chunks are loaded and sometimes get stuck within the blocks after the chunk is loaded and sometimes work correctly and the player is pushed upwards to a safe location.

    I have noticed a lot recently when i as an admin teleport around the first set of chunk that load is where i am looking and not below my feet till a split second later, within this split second i notice myself inside blocks then pushed upwards after the chunk loads below my feet. With me being admin i dont take damage so i do not die but normal players will tend to get stuck inside the blocks on rare occasions and killing them due to suffocation being one and unable to use commands to get out due to having a delay set for using any teleport commands and the command cancels when taking damage.
     
    • Agree Agree x 2
  14. Just to update this, i have updated both my servers to 387 and can confirm this is still hapening. Now my PVE server players have instant /spawn and /home so none of my pve players die but they do get stuck inside blocks after a teleport or even log in on rare occasions. As for my pvp server i have had to disable suffocation due to many players dying due to this bug.

    My pvp server is a prison and suffocation really needs to be enabled as players are unable to set mine traps on other players as suffocation is disabled. Reason i must disable suffocation on my prison server is when players die they lose mcMMO skills and money not to mention what they have in their inventory which is worse then not being able to set mine traps. It is not fair my players should suffer due to a big that is killing them on teleport or log in.

    Please try and look deeper into this issue as it is a pretty major issue and has to have something to do with how spigot loads chunks on log in and/or teleporting.
     
    • Agree Agree x 2
  15. This is still happening on build 23-gfb19aa6 and on both my servers i run. Also why has the /version changed, now unable to see the actual build number to match with jenkins.
     
    • Like Like x 1
    • Agree Agree x 1
  16. Still continues in build 417. Mostly happens at log in. Randomly happens when players use /home or /f home or any teleport feature teleporting them to a new unloaded chunk location.

    When logging in the server puts you 1-2 blocks below ground then may or may not push you upwards to a safe location. If the server does not push you upwards to safe locations you are stuck inside the blocks and will die due to suffocation (if enabled) which i have had to disable suffocation due to this glitch.
     
    • Agree Agree x 1
  17. Puremin0rez

    Moderator

    I was able to work around this annoyance by setting WorldGuard to teleport players upon suffocation
    (teleports them to the top of the block)
     
  18. I am unable to do this due to how my prison server is run. Players are allowed to make and use mine traps and if a player gets sand dropped on them wouldnt world guard teleport the player suffocating? Which would defeat the purpose of mine trapping.
     
  19. Puremin0rez

    Moderator

    Yep, you'd be correct - traps like that would cease to work. My workaround doesn't apply to everyone :)

    Have we already came to the conclusion that it's a Spigot issue? Because this sort of thing happens quite often on my FTB server which obviously does not run Spigot.