People Spawning In Incorrect World

Discussion in 'Spigot Plugin Help' started by Tyleranthony7, May 21, 2016.

  1. Hello. My server has been up for a couple of days but just today people have been spawning in another world and not the spawn world with the spawn. I have MV and /mv setspawn , I /setworldspawn and all other commands,I went into the config in MV and set first join spawn to the correct spawn and in essentials have newbies first spawn point set to the correct one. Anyone have this happen to them or know how to fix this?
    I haven't added in any plugins in a few days also.
     
  2. Try turning your server off, and then change the config files.
     
  3. MultiWorld does not allow you to set a certain world as default. You should change level-name in to your server.properties instead. Don't forget to restart.
     
    • Agree Agree x 1
  4. People do, you just have to give them time, and I'm sure you can set a world spawn in Multiverse.
     
  5. Code (Text):
    multiverse-configuration:
      ==: com.onarandombox.MultiverseCore.MultiverseCoreConfiguration
      enforceaccess: 'false'
      prefixchat: 'false'
      teleportintercept: 'true'
      firstspawnoverride: 'true'
      displaypermerrors: 'false'
      globaldebug: '0'
      messagecooldown: '0'
      version: '2.9'
      firstspawnworld: world #Set your world here.
      teleportcooldown: '0'
     
    • Useful Useful x 1
  6. firstspawnoverride: 'true'
    firstspawnworld: world #Set your world here.
    Those two lines would be the ones to override the already set spawn you have. Making MV use the spawn and not essentials or whatever you're using.
     
  7. Thank you. :)
     
  8. My bad, I thought he was using MultiWorld instead. Indeed, with MultiVerse it's possible as @NotWhiteyLol showed above.
     
    • Like Like x 1
  9. Just like you said, Multiverse Overrides the EssentialsSpawn section of Essentials and straight up teleports them to the spawn configured in Multiverse when the world was created/imported. Let me know if it works for you now :D
    @Tyleranthony7
     
    • Like Like x 1
  10. It's fine, there's a few multiworld creation plugins out there. xP But I'm not sure which one he uses or if any. :/
     
    • Friendly Friendly x 2
  11. I have it set as that world.
     
  12. You need these two lines changed:
    firstspawnoverride: 'true' <------ Needs to be true.
    firstspawnworld: world #Set your world here.
     
  13. This did not work.
     
  14. Check spawn.yml in essentials. Check worlds folder in Multiverse. In the world folder of Multiverse you will find world settings. Like spawns etc.
     
    • Like Like x 1
  15. Yeah those are the "first" spawns, meaning when a player joins for the first time that is where they will spawn, try setting the essentials spawn to the same place too. :) That should work.
     
  16. I want it to be where they first spawn. It does not work.
     
  17. What Minecraft version you using?
     
  18. Change it in ur essentials config so essentials handles respawns