Solved Permission.ex is not working

Discussion in 'Spigot Plugin Development' started by Graham1337, Feb 4, 2020.

  1. Hey, I'm relatively new to this stuff and wanted to ask for help. I tried to "learn" how to setup your own permission. ex file and tried to do everything like it was explained in the forums, videos etc. I followed the steps and pasted it into the file. When I tried to /pex reload it said I had some errors I don't know what I to do or what I did wrong. So my last hope is to find help here

    My permission file: https://pastebin.com/XKMngu2A

    Would appreciate if someone could help me and tell me what I did wrong and how I can fix that.

    Thanks

    PS: Before I start I'm new to the forum and I don't know if this is the right place to ask this kind of questions.
     
    • Agree Agree x 2
    • Like Like x 1
  2. Your file is wrong, you should check the permissions ex wiki. But i will do your job...the wrong things there is:
    First default and prefix options need to be under options: like you have ranks.
    Another thing on inheritance you dont need to put all the other groups, your potatoe group inheritance mini-potato, so on potato knight you dont need to put mini-potato if you already put potato, cause potato already inheritance all permissions from mini-potato
     
    • Informative Informative x 1
  3. It has also happened to me, i solved by changing PEX version, maybe is not the right version for your server.
     
    • Like Like x 1
  4. Thanks, I try my best could you help me a bit more if it still doesn't work? Would highly appreciate it
     
  5. Okok just write me a message! However if i helped you i would be thankfoul for a +positive rating <3
     
  6. Of course, whatever you need send me a message
     
    • Friendly Friendly x 1