permissionEx help

Discussion in 'Spigot Plugin Help' started by gamer00565, Mar 9, 2020.

  1. Greetings, i have problem. I maked a prefix with permission . with options all okay. Permission is working but prefix don't show. Help
     
  2. RobiGames

    Supporter

    Hey @gamer00565!
    Can you add your PermissionsEx config file as a spoiler?
    But... Maybe you used commands wrongly - /pex group <group> set prefix <prefix>

    Side question: Does your server have a certain gamemode (factions, survival, etc) or other plugins that can change the chat format?
     
  3. No. My server dont have plugins what can change the format.
     
  4. config.png 1-config 2-permissions permissions.png
     
  5. Ummm did you tried to add your self in a group even? try add your self to a group and then check. /pex group <group> user add <user> i think, long time i didn't use pex so i don't remember. Also i recommend you use LuckPerms its safe, trusted and better.
     
  6. RobiGames

    Supporter

    Also, if you are using Essentials then have you changed EssentialsChat settings or format?
     
  7. luck perms is hard plugin for me
     
  8. Screenshot_1.png ummm nickname dont need to be red and where is prefix??
     
  9. RobiGames

    Supporter

    Can you send a list of plugins?
    And if you use command /pl then PermissionsEx is red or green?
     
  10. Your name is red because you are op! as what i see in your permission file (permission.yml) theres no any users added. there just 2 groups user and VIP but there no any user. Please add your self in one of groups then try it again. Till you don't add someone in a group, they won't get any prefix. Also if the op color (red name) is annoying, change it in essentials (set ops-name-color: to 'none') then op names will white.
     
    • Like Like x 1
  11. okay thx
     
  12. yes of course. green
     
  13. Screenshot_5.png
     
  14. Uhh okay fuck it pex i download luckperms
     
  15. Here's a coffee and relax :coffee: , if you

    1. Never place yourself in a group
    2. Never solve the issue that may not be the permission plugin's fault

    You will never solve the issue.