permissionEX(PEX) rank only shows {Prefix}

Discussion in 'Spigot Plugin Help' started by xMicro, Jun 18, 2019.

  1. I have PermissionEX plugin on my server and I have been trying to figure this out I have the essentialsX chat and every-time i log in instead of being no prefix or a rank it says beside my name {Prefix} I have looked at every video, I tried deleting all of my plugins and re-adding them and before it did nothing and now since re-adding all of the plugins it has only said {Prefix}
     
  2. What plugins do you have on server?
    send us please your permissions.yml (in code format or hstebin.com / pastebin.com)
     
  3. https://hastebin.com/ribopewawa.cs

    Plugins:
    bStats
    Clearlag
    ControlTPA
    CoreProtect
    DeluxePlayeroptions
    EssentialsXSuite
    GriefPreventionData
    MassiveCore
    Multiverse-Core
    Multiverse-Portal
    Multiverse-SignPortals
    Multiverse-NetherPortals
    NoCheatplus
    OpenInv
    PermissionsEx
    Perworldchat
    perworldinventory
    perworldhomes
    SuperLobby
    Supervanish
    Vault
    Warps
    Factions
    LibsDisguiser
     
  4. Sorry I couldnt put my mods into a folder, I am running under Nodecraft.com
     
  5. Well, can you please send multiverse-core config and config from essentials - section essentialsChat
     
  6. I would check out the configuation of 'perworldchat' as a starting point, provided that the prefix has been correctly applied to PermissionsEx.
     
  7. I've deleted every single plugin and single placed a rank mod i got rid of permissionsex for now i'm trying other plugins like Luckperms that a plugin creator recommended. It still is unsuccessful on the server no prefixes are showing.
     
  8. Firstly, It doesn't really matter which permissions plugin you use (for a single server), so long as the permission is correctly applied.

    Secondly, it is how the 'chat' plugin is configured to use the prefix and any required permissions (if they are an extra requirement).
     
  9. Your essentialsX config for group formats/chat setup should look something like this.

    Code (Text):
      group-formats:
        member: '{DISPLAYNAME}:&7 {MESSAGE}'
        survivor: '{DISPLAYNAME}:&f {MESSAGE}'
        explorer: '{DISPLAYNAME}:&f {MESSAGE}'
        admin: '{DISPLAYNAME}:&2 {MESSAGE}'
        owner: '{DISPLAYNAME}:&2 {MESSAGE}'
    You can also include the {GROUP} tag
     
  10. My bad forgot to mention to disable multiverse handling of chat tags. Its in the config somewhere..