PermissionsEX Disabled HELP!!

Discussion in 'Spigot Plugin Help' started by Fininja5, Jul 18, 2018.

  1. Permissions ex is disabled and i don't know why! Please tell me whats wrong. Thank you. I hope im not just noobing out. Here is the permissions.yml file


    https://pastebin.com/8rg5wrBh
     
  2. Aeternum

    Supporter

    Code (Text):
    groups:
      default:
        options:
          default: true
        permissions:
        - essentials.warps.spawn
        - modifyworld.*
      Owner:
        options:
          prefix: '&0[&5Owner&0]'
      YT:
        options:
          prefix: '&0[&3YT&0]'
        permissions:
        - worldguard.heal
      Friend:
        options:
          prefix: '&0[&1Friend&0]'
      FIRST:
        options:
          prefix: '&0[&bFIRST&0]'
      Co-Owner:
        options:
          prefix: '&0[&6Co-Owner&0]'
      Helper:
        options:
          prefix: '&6[&aHelper&6]'
      Mod:
        options:
          prefix: '&6[&aMOD&6]'
    schema-version: 1
    users:
      d4554bfc-28e0-47cf-ac36-c8479e96f7e3:
        permissions:
        - '*'
        group:
        - Owner
        options:
          name: Fininja5
      dcf6d458-6ec0-454e-9cc3-54e2b136e27f:
        group:
        - Co-Owner
        options:
          name: Fun4Bros
      c1b3c582-ea8d-4506-852a-4c9f4e9d1cea:
        group:
        - supreme
        options:
          name: JoninjaYT
      db6edf4f-a969-49ee-9ce8-a07c35822ff0:
        group:
        - Mod
        options:
          name: ZestyTamale
     
  3. Aeternum

    Supporter

    You didnt put the permission - essentials.warps.spawn on its own line with a hyphen.
    [​IMG]
     
  4. #4 Fininja5, Jul 18, 2018
    Last edited: Jul 18, 2018
  5. Aeternum

    Supporter

    Joninja is also the member of a non existent group "supreme". And I just booted it up and pex accepts it.
     
  6. so I should get rid of supreme?
     
  7. Aeternum

    Supporter

    And you didnt make the change completely, each permission has to be on its own line and have a hyphen in front of it. I posted the proper way to enter it above.
     
  8. Aeternum

    Supporter

    You currently have:

    Code (Text):
    groups:
      default:
        options:
          default: true
        permissions:essentials.warps.spawn
        - modifyworld.*
        - essentials.warps.spawn
    And you need:

    Code (Text):
    groups:
      default:
        options:
          default: true
        permissions:
        - modifyworld.*
        - essentials.warps.spawn
     
  9. OMG THANK YOU SO MUCH! Its fixed!
     
  10. Aeternum

    Supporter

    No problem.