PermissionsEX help

Discussion in 'Spigot Plugin Help' started by Marius1999, Feb 13, 2020.

  1. This is the error that appears in the console and in / pl, it appears in red ...



    [ERROR] [PermissionsEx]

    ========== UNABLE TO LOAD PERMISSIONS BACKEND =========

    Your configuration must be fixed before PEX will enable

    Details: Error loading permissions file!

    =======================================================

    ru.tehkode.permissions.exceptions.PermissionBackendException: Error loading permissions file!

    at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:321) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.backends.file.FileBackend.<init>(FileBackend.java:120) ~[PermissionsEx-1.23.4.jar:?]

    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_212]

    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_212]

    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_212]

    at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_212]

    at ru.tehkode.permissions.backends.PermissionBackend.getBackend(PermissionBackend.java:392) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.backends.PermissionBackend.getBackend(PermissionBackend.java:367) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.PermissionManager.createBackend(PermissionManager.java:624) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.PermissionManager.setBackend(PermissionManager.java:606) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.PermissionManager.initBackend(PermissionManager.java:693) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.PermissionManager.<init>(PermissionManager.java:67) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(PermissionsEx.java:175) [PermissionsEx-1.23.4.jar:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:342) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:314) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:406) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:370) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:325) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:235) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at java.lang.Thread.run(Thread.java:813) [?:1.8.0_212]

    Caused by: org.bukkit.configuration.InvalidConfigurationException: while scanning for the next token

    found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)

    in 'string', line 4, column 1:

    default: true

    ^

    at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:57) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at ru.tehkode.permissions.backends.file.FileConfig.loadFromString(FileConfig.java:68) ~[PermissionsEx-1.23.4.jar:?]

    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:226) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:169) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at ru.tehkode.permissions.backends.file.FileConfig.load(FileConfig.java:38) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:309) ~[PermissionsEx-1.23.4.jar:?]

    ... 23 more

    Caused by: org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token

    found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)

    in 'string', line 4, column 1:

    default: true

    ^

    at org.yaml.snakeyaml.scanner.ScannerImpl.fetchMoreTokens(ScannerImpl.java:420) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.scanner.ScannerImpl.checkToken(ScannerImpl.java:226) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingValue.produce(ParserImpl.java:586) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:132) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.yaml.snakeyaml.Yaml.load(Yaml.java:369) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:55) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at ru.tehkode.permissions.backends.file.FileConfig.loadFromString(FileConfig.java:68) ~[PermissionsEx-1.23.4.jar:?]

    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:226) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:169) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

    at ru.tehkode.permissions.backends.file.FileConfig.load(FileConfig.java:38) ~[PermissionsEx-1.23.4.jar:?]

    at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:309) ~[PermissionsEx-1.23.4.jar:?]

    ... 23 more

    [INFO] [PermissionsEx] Disabling PermissionsEx v1.23.4
     

    Attached Files:

  2. There's a spacing issue in your config.yml of PermissionsEX. It says where it's located, which is in line 4.
     
  3. Look at my permissions.yml
     

    Attached Files:

  4. You can't use the TAB key in yaml
    You need to use four spaces rather than a tab. I've fixed the errors, here's what you need to copy paste into your file:

    Code (Text):
    groups:
      miembro:
        options:
          default: true
          prefix: '&8&lMiembro'
        permissions:
        - essentials.fly
        - essentials.warp
        - essentials.warp.list
        - essentials.warps.*
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpdeny
      builder-n:
        inheritance:
        - miembro
        options:
          default: false
          prefix: '&6&lBuilder &8&lN'
        permissions:
        - modifyworld.*
        - essentials.fly.safelogin
        - essentials.gamemode
        - essentials.gamemode.all
        - essentials.give
        - essentials.speed
        - essentials.speed.fly
        - essentials.signs.color
        - essentials.balancetop.exclude
        - essentials.time
        - essentials.time.set
        - multiverse.access.*
        - essentials.top
        - worldedit.*
        - worldguard.*
      builder-p:
        inheritance:
        - miembro
        - builder-n
        options:
          default: false
          prefix: '&6&lBuilder &3&lP'
      builder-e:
        inheritance:
        - miembro
        - builder-n
        - builder-p
        options:
          default: false
          prefix: '&4&lBuilder &5&lE'
      builder-pf:
        inheritance:
        - miembro
        - builder-n
        - builder-p
        - builder-e
        options:
          default: false
          prefix: '&6&lBuilder &2&lPF'
      manager:
        inheritance:
        - miembro
        - builder-n
        - builder-p
        - builder-e
        - builder-pf
        options:
          default: false
          prefix: '&c&lMANAGER &f|'
        permissions:
        - '*'
      creador:
        inheritance:
        - miembro
        - builder-n
        - builder-p
        - builder-e
        - builder-pf
        options:
          default: false
          prefix: '&4&lCREADOR &f|'
        permissions:
        - '*'
    schema-version: 1
     
    • Agree Agree x 1
  5. Strahan

    Benefactor

    FTFY. The key isn't the issue, the \t is. I use TAB key all the time in YAML :)
     
  6. don't use TAB in yaml
     
    • Like Like x 1
  7. Strahan

    Benefactor

    Yea, we covered that ;)