Solved PermissionsEx, nothing works anymore.

Discussion in 'Spigot Plugin Help' started by Vauhwi, Dec 21, 2016.

  1. Hello,
    My name is Vauhwi,
    Co-Owner of the TutoNetwork.

    I had everything setup correctly in PermissionsEx, and it all worked perfectly.
    Recently I added the plugin Rankup, by Okx. (I don't think that's what messed it up though,
    I also messed with some permissions; I removed essentials.chat.color and switched some permissions around).
    Now nothing works anymore, it shows the world I'm in, and these ugly stupid brackets are back <>. Also there's no more prefixes, no more permissions,..And I can't use any of the permissionsex commands. Here is my PermissionsEx config file: http://pastebin.com/TiJ6Uwes
    Please help me, this is frustrating.

    Thanks so much for your help in advance, hope you have a wonderful day.
    -Vauhwi
     
  2. If it displays the world name in the chat before the players name you need to execute the following command: "/mv config prefixchat false/deny". If you wish to get rid of the '<>' you need to go download EssentilsChat.jar and then change the format in the 'Essentials/config.yml'
     
  3. The thing is I did all that, always had essentialschat, etc. It's just a typo/mistake in the config that ruins everything and I don't know what it is.
     
  4. Solved. A group ruined it all, deleted it and it worked.
     
  5. Even though this thread is already solved, just for future notice for anyone having a similar issue, another cause for this can be the permissionsex file. If all the groups stop working and the pex commands don't work either, check the file size of the pex file, and if it isn't at its usual size, and has changed to 1kb, you need to replace the file.