PermissionsEx prefix not working!

Discussion in 'Spigot Plugin Help' started by ShockShore, Dec 26, 2017.

  1. I have experience with PermissionsEx and coding, and I usually can figure out what's wrong. I've been stuck on this problem for a while and need a lending hand. My permissions work fine on the plugin but the prefixes will not show up. I am on 1.12.1 and I am using essentials chat.
  2. Could you provide us with your configuration? (Permissions.yml)
  3. I already have EsssentialsChat
  4. Are both Essentials and EssentialsChat correctly installed and running?
  5. Yes
  6. I know they are both working fine because my permissions work on EX and my chat works on Essentials Chat. I deleted the < > and that worked.
  7. Do you use factions by any chance?
  8. No, the only plugins I am using are Essentials, Multiverse, Pex, Plugman, & WorldEdit
  9. Do the permissions work or does the whole permissions plugin not work. Also try adding def╬▒ult: false to both of your other groups (just in case that's the fault)
    #10 Norska, Dec 26, 2017
    Last edited: Dec 26, 2017
  10. I had the same problem. I use ChatEx. However, the tags do not show in the tab list or on the tag of the user, but it shows the prefix or suffix in chat.
  11. Did you enable the prefix in tabs?
  12. May I see the configuration of your essentials chat? "Essentials > config.yml > Essentials Chat"

    To have prefix in tabs, use a plugin like NameTagEdit and add a permission for each group and transfer those permission into pex accordingly
  13. The permissions work, just not prefixes.
  14. I really don't know at this point, sorry. I bet it's something stupid and obvious though xD
  15. :(
  16. U completely ignored the fact that I tried to help, would you please check the reply I mentioned above?
  17. Even if he did I don't think that it has something to do with EssentialsChat since PermissionsEX should show prefixes / suffixes etc. on their own (At least on my server that's how it works). I believe the issue is somewhere else, maybe an incompatible or outdated PermissionsEX plugin, or another plugin that interferes with chat formats.
  18. I'd recommend LuckPerms. Way easier to use, and just overall a better plugin. Also its free!
  19. Actually, essentials chat is what makes the prefix show in chat, I've used pex and still use it.