Solved Permissionsex prefixes not showing.

Discussion in 'Spigot Plugin Help' started by anakinsky249, Apr 26, 2017.

Thread Status:
Not open for further replies.
  1. Do you have Vault installed?
     
  2. Could you show us your Essentials config.yml? Just the EssentialsChat part.
     
  3. The prefix would go under options as you can see in below e.g.

    groups:
    default:
    default: true
    options:
    prefix: '[&3Member&r] &b'

    permissions:
    - {perms here}

    P.S.: There are spaces in front but this post neglects them.
     
    • Like Like x 2
  4. You must have a chat plugin like EssentialChat
     
  5. ...
     
  6. Oh i'm sorry... Try to use another chat plugin
     
  7. I tried using Ess. Chat with this too, it's not compatible. Nothing you change in config can fix this; Essentials Chat will only work with GroupManager, which is outdated. I use ChatEx with PEX and it works perfectly. Make sure to delete the EssChat jar and replace it with ChatEx.
     
  8. I've used EssentialsChat with PEX many times, it's just that PEX doesn't handle the prefixes/suffixes like GroupManager does; GP does it just appending it to the player's display name while PEX uses real prefixes/suffixes (team prefixes and suffixes). To make it work with PEX you just have to put the placeholders "{PREFIX}" and "{SUFFIX}" on the chat format.
     
  9. Thanks, you were right, I had to put theses inside the options.... I was using an old example...
     
Thread Status:
Not open for further replies.