PermissionsEx Problems

Discussion in 'Spigot Plugin Development' started by Recay_Shark, Apr 29, 2017.

Thread Status:
Not open for further replies.
  1. Currently set up a sever on localhost so i can use cool plugins but play alone. However, I would like to make it online so before i do I didn't want everyone destroying everything so i want to create permissions.

    anyway my problem is that permissions all together just do not work, as a guest i cannot do any commands except like /pl i cant do /help or /tpaccept and i have not prefix?

    https://pastebin.com/jjmxgPkv

    this is my code for the permissions.yml file, i have used default templates to see if that was the problem but it still occurs, I think it maybe my plugins but i have tried various solutions, also guests can build :/

    PermissionsEx, PermissionsExTabColors, WorldEdit, HolographicDisplays, Essentials, Vault, EssentialsSpawn, EssentialsChat, WorldGuard, UltraCosmetics

    I have tried using EssentialsX using ChatEx even installed PermissionsExTabColors.
    I am clueless on what the problems is and is very irritating. Any help is appreciated thanks :)
     
    #1 Recay_Shark, Apr 29, 2017
    Last edited: Apr 29, 2017
  2. I would use to not give them all the permissions and then removing them I would just give them the permissions of what they are allowed to
     
  3. i've edited the post still doesn't work
     
  4. Can you please give me the version of your server and the version of PermissionsEx?
     
  5. Did you try to run PEX and essentials only to test if its another plugin that is doing the stuff?
     
  6. i will try that now
     
  7. no tried a lot of different variations still doesn't work,
    I've deleted essentialschat and installed chatex, looked at the config file and got it running howver when im not in a group my name is
    <Recay_Shark>: (MESSAGE)
    and when i am in a group it's
    Recay_Shark: (MESSAGE)
    howver in a group with prefixes the prefixes don't show?
     
    #9 Recay_Shark, Apr 29, 2017
    Last edited: Apr 29, 2017
  8. wrong section af... use "Spigot Plugin Help" for this...
     
  9. Yeah I've kinda figured out the problem, still some errors but the formating with pex is different to what i have, i deleted all my code from permissions.yml and opened up my server, added groups and permissons inside minecraft and seen he formatting in permissions.yml then went from there, thanks for the help anyway :)
     
Thread Status:
Not open for further replies.