Solved PermissionsEx Setup - How to fix yours!

Discussion in 'Spigot Plugin Help' started by PiggiesGoSqueal, Jun 4, 2016.

  1. Hey guys. I've recently made a minecraft spigot 1.8.8 server that uses multicraft for the console and is hosted by GGServers. I made a list of permissions but when I saved the file and restarted the server, some of the permissions didn't work. Mods couldn't talk even though they inherited that command from the default group and there were many other problems.
    To give you an idea of what it looks like in the multicraft for GGServers: http://prntscr.com/bcdncd
    -----------------------------------------------------------------------------------------------------------------------
    I'm happy to announce the problem has been fixed. I'll now be sharing how I fixed it and my current permissions file setup so anyone else having similar problems in the future can save their time and fix their problems! Feel free to use my permissions setup if you want!

    What I used to fix it:
    http://www.configcreator.com/create/minecraft/permissions.yml

    Permissions file setup:
    http://pastebin.com/aRk0qEfd
     
    #1 PiggiesGoSqueal, Jun 4, 2016
    Last edited: Jun 5, 2016
  2. Let me list your problems:

    Inhertiance can just be:
    inheritance:
    - default
    - trail-mod
    ...
     
    • Useful Useful x 1
  3. PermissionsEx can be set-up for the most part with in-game commands. It might be easier to use the commands to set up your permissions and groups, instead of writing out a permissions file, so that way, you don't need to worry about errors like this.
     
    • Useful Useful x 1
  4. Ohh ok thanks for the information and fast reply! :D
     
  5. Come on! get code tags! [ code] [/ code]
     
  6. (and a up to date server + better server host :mad:)
     
  7. I wanted it to be 1.8.8 because I prefer it compared to 1.9
    Also, GGservers has better prices for more memory then the other hosts I've seen. But do you know any other server hosts that are better?
     
    • Useful Useful x 1
  8. If you can learn how to manage a Linux OS;
    [​IMG]
    3.62 EUR for 2GB ram = 1.81/GB
    GGServers = $3/GB