Spigot PermissionShopZ - The #1 Permission Shop 2.0.0

Allows players to buy permissions! Supports ALL permission managers!

  1. would m and h work as well? how about d? asking because I'm not sure it putting in 2678400s is a good idea :) (one month, in seconds)
     
  2. It uses TabuuCore time strings, so: ms (millisecond), s (second), m (minute), h (hour), d (day), and y (year) would all work :). Technically putting 2678400s would work just fine, just not as readable I think :).
     
    • Useful Useful x 1
  3. I am not sure if you would consider this a bug or not, but the shop cannot be edited and reloaded from the file while the server is running; What I mean by that, is if I hand edit the shop.json and reload the plugin, the changes don't take effect, and, when I restart the server the changes are then lost. When I can, I edit files directly because it tends to be faster than a GUI
     
  4. It is not a bug, the files gets saved when reloaded. Else the changes made in the gui would not be saved.
     
  5. I think should be able to set the permission timeout.
     
  6. Timed permissions work with this Tabuu explains it above (is that what you're asking for?)
     
  7. Please make update 1.17 .)
     
  8. I can't access the second page on the editing menu, but it works fine on the normal shop.
    I'm using Paper Spigot 1.16.5 build #779 on java 8.
     
  9. This version will work if you use the right version of TabuuCore.
     
  10. The issue will be fixed in the next release.
     
  11. Thanks for the very nice plugin.
    However, when I type in Japanese, the text is garbled.
     
  12. Hey there! thanks a ton for the update. One thing though, I am having a bit of trouble with the editor. I input everything, but I never see a way to save my newly created shop item. Would there be a way to edit shop items via text editor instead? Or, Do you have any ideas what I might be doing wrong? Thanks again.

    Edit: I figured it out. There is no save button. I watched your videos about the new features you put out a while ago and that showed me how to do it. Thanks again! I look forward to building out my shop and testing it in full
     
    #93 Cyats, Sep 3, 2021
    Last edited: Sep 3, 2021
  13. EDIT: SOLVED, I had to change VAULT to LUCK_PERMS in the config, as you say in your tutorial video :D Works fine now as far as I can tell

    Timed permissions do not seem to be working. When I look in the editor they are added as regular permissions. Not permissions with expiration dates. I've tried both 30d and 5s, neither seems to expire, or have an expiration date. Would it work if I did something like cmi.command.launch:30d?

    I am using Purpur, and Luckperms
     
    #94 Cyats, Sep 5, 2021
    Last edited: Sep 5, 2021
  14. Question: Can I change the numerical names of Perks and Nodes in order to make the code more legible? Basically I want to change something like

    "6": {
    "Name": "Death Proof (30 days)",
    "Cost": 75000.0,
    "Item":

    into;


    "deathproof": {
    "Name": "Death Proof (30 days)",
    "Cost": 75000.0,
    "Item":

    would that work, or would it cause issues? Obviously I would change all references to the new name, so in the shop.yml I would replace "6" with "deathproof"
     
  15. Hi, is it possible to update the plugin for 1.18, its about the InventoryClickEvent on TabuuCore.
     
    • Agree Agree x 1
  16. I am having the same issue. I know 1.18 is new but this plugin seems to be the answer to all my problems since you can't use target selectors in LuckPerms commands.

    Full support and thank you for this plugin @Tabuu =)
     
  17. Hi, all!

    TabuuCore (2.4.0) now has 1.18 & 1.18.1 support!

    Download it to give PermissionShopZ 1.18 & 1.18.1 support as well :).

    - Tabuu
     
  18. Unfortunately that would not work
     
  19. Hey there. Just installed the plugin today. And I'm running into issues... Not sure if its due to the fact that we just updated to 1.18.2 paper or something else, but when I try to edit the Perk and it's supposed to open up the anvil menu it just wont do anything. I check console and this error is showing up when I click this like Edit Name, or Add Permission Node


    [21:01:55 ERROR]: Could not pass event InventoryClickEvent to TabuuCore v2.4.0
    java.lang.UnsupportedOperationException: Class with name container.AnvilContainerWindow was not found for NMS version 'UNKNOWN'!
    at nl.tabuu.tabuucore.nms.NMSUtil.getWrapperClass(NMSUtil.java:54) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.nms.wrapper.container.IContainerWindow.get(IContainerWindow.java:23) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.TextInputUI.createInventory(TextInputUI.java:113) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.InventoryUI.initialize(InventoryUI.java:43) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.InventoryUI.initialize(InventoryUI.java:38) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.TextInputUI.open(TextInputUI.java:91) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.element.TextInput.click(TextInput.java:55) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.inventory.ui.InventoryFormUI.onClickUI(InventoryFormUI.java:86) ~[TabuuCore-2.4.0.jar:?]
    at nl.tabuu.tabuucore.event.listener.InventoryListener.onInventoryClick(InventoryListener.java:41) ~[TabuuCore-2.4.0.jar:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor1308.execute(Unknown Source) ~[?:?]
    at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:75) ~[paper-api-1.18.2-R0.1-SNAPSHOT.jar:?]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[paper-api-1.18.2-R0.1-SNAPSHOT.jar:git-Paper-268]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[paper-api-1.18.2-R0.1-SNAPSHOT.jar:?]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:629) ~[paper-api-1.18.2-R0.1-SNAPSHOT.jar:?]
    at net.minecraft.server.network.ServerGamePacketListenerImpl.handleContainerClick(ServerGamePacketListenerImpl.java:2860) ~[?:?]
    at net.minecraft.network.protocol.game.ServerboundContainerClickPacket.handle(ServerboundContainerClickPacket.java:58) ~[?:?]
    at net.minecraft.network.protocol.game.ServerboundContainerClickPacket.handle(ServerboundContainerClickPacket.java:13) ~[?:?]
    at net.minecraft.network.protocol.PacketUtils.lambda$ensureRunningOnSameThread$1(PacketUtils.java:51) ~[?:?]
    at net.minecraft.server.TickTask.run(TickTask.java:18) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.util.thread.BlockableEventLoop.doRunTask(BlockableEventLoop.java:153) ~[?:?]
    at net.minecraft.util.thread.ReentrantBlockableEventLoop.doRunTask(ReentrantBlockableEventLoop.java:23) ~[?:?]
    at net.minecraft.server.MinecraftServer.doRunTask(MinecraftServer.java:1399) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:188) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.util.thread.BlockableEventLoop.pollTask(BlockableEventLoop.java:126) ~[?:?]
    at net.minecraft.server.MinecraftServer.pollTaskInternal(MinecraftServer.java:1376) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.server.MinecraftServer.pollTask(MinecraftServer.java:1369) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.util.thread.BlockableEventLoop.managedBlock(BlockableEventLoop.java:136) ~[?:?]
    at net.minecraft.server.MinecraftServer.waitUntilNextTick(MinecraftServer.java:1347) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.server.MinecraftServer.runServer(MinecraftServer.java:1229) ~[paper-1.18.2.jar:git-Paper-268]
    at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:315) ~[paper-1.18.2.jar:git-Paper-268]
    at java.lang.Thread.run(Thread.java:833) ~[?:?]

    Tried guessing what the issue is an it's most likely that NMS version. Any ideas on how to fix this?