Solved PEX Multi-Ladder Prefixes

Discussion in 'Spigot Plugin Help' started by TheChainPickAxe, Jul 12, 2018.

  1. Basically, I have created two ladders using PermissionsEx on my server, the "player" ladder and the "staff" ladder.

    The "player" ladder consists of groups such as "D-Prisoner", "C-Prisoner" ... etc whereas the "staff" ladder consists of groups such as "Moderator" and "Owner".

    When I add players to a group from both ladders, only one of their prefixes show up in-game. For example, I'm the owner and also a d-prisoner, but I cannot get both the owner and d-prisoner prefixes for some reason.

    So even if my config file looks like this:

    groups:
    D-Prisoner:
    options:
    default: true
    rank: '1000'
    rank-ladder: player
    prefix: '[&7D-Prisoner&f] '
    Owner:
    options:
    rank: '1'
    rank-ladder: staff
    users:
    7dcffb71-871c-4927-a921-871d3301f54b:
    permissions:
    - permissions.*
    options:
    name: TheChainPickAxe
    group:
    - Owner
    - D-Prisoner

    Both prefixes do not show. How can I fix this, assuming I can.

    Edit: There is nothing wrong with the layout of my yml file.
     
  2. If you have want to have 2 prefixes to show both at the same time. I would suggest you to use a suffix for staff.
    If you then in your Essentials config make the format like this
    Code (Text):
      format: '&7{SUFFIX}&r&7{PREFIX}&r{DISPLAYNAME}&r: {MESSAGE}'
    You can put staff as a suffix and the rank as a prefix.
    Here is the result. You see I am Grand-Master rank but my prefix is my job title.
    [​IMG]
     
    • Like Like x 1
  3. Aeternum

    Supporter

    You also don't need to have two separate ladders just for players and staff. Groups whos ranks are in the 1-100 range cannot be promoted via command by user. But are still promote able via console. You would want to use different ladders if say, you had your prison ranks, and then you also had paid ranks that were independent.
    Ive also made ladder, rank, suffix and prefix management super easy in my webdashboard for pex: https://github.com/Aeternum-Studios/PermissionsEx/releases
     
    • Like Like x 1
  4. I use ChatEx, so I went to the config file for that and simply enabled mutli-prefixes. Thank you. :p
     
  5. Np make sure to mark this thread as solved to let other know that this question has been solved :p
     
    • Informative Informative x 1
  6. But if you are D-prisoner with staff preffix you dont have staff perms
     

Share This Page