PEX Not Working

Discussion in 'Spigot Plugin Help' started by DannyWeston, Apr 22, 2017.

  1. Hey everyone! After loading up my server I had a whole while ago Pex doesn't want to work.

    No errors show in the console, nothing whatsoever.

    I have noticed that the .jar file for Pex tends to change from the default size to 190 Bytes after loading it up, so I am wondering if that points to anything whatsoever?

    I have tried reinstalling Pex, Essentials, and its honestly quite frustrating that the console has no information on whats going on!

    Thank ya for reading, and have a lovely day :)
     
  2. Are you using the latest version of Pex?
     
  3. I have tried multiple different versions such as 1.23, and all the sub-versions (I am running 1.8 with Via Version but it worked without any flaws in the past.) I would just switch to group manager but I need the tree system of Pex where you can have 2 groups at once (with two sets of permissions) and as far as I am aware you can't belong to 2 groups in group manager).
     
  4. What do you mean by it doesn't work? Can you still post a console log?
     
  5. What does it say when you try to do "/pex" in-game?
     
  6. Doesn't detect the plugin at all.

    Basically in order what happens:

    1. Server started, only with Pex jar (and not config files) and loads up correctly.

    2. Pex works fine on 1st loadup.

    3. Restart the server (tried /reload too)

    4. Server loads up fine, doesn't mention any errors about Pex.

    5. Do /pl in-game and Pex is missing from there (so the command says "Unknown command")

    6. Check the files on FileZilla and the Pex jar changes from however big it usually is to 190 bytes in size.


    **From step 3 and onwards, I tried adding the permissions.yml and the config.yml files I was previously using and that has no effect either.
     
  7. I believe this is my latest console log, but correct me if I am wrong!

    Also the filesize.
     
    #7 DannyWeston, Apr 23, 2017
    Last edited: Apr 23, 2017
  8. Okay, so after trying to update to that version, even though I tried countless times already, it seems to have solved the problem. HOWEVER, now the chat formatting will not work at all in-game. Any ideas as to what could be causing it? The permissions are working fine though. :)
     
  9. Do you have Vault and a chat formatting plugin like Essentials Chat installed?
     
  10. For the formatting I am doing through the prefixes/suffixes in the permissions.yml and ChatEx, but upon running /plugins ChatEx has now decided it doesn't want to appear either :(
     
  11. Make sure you're running the latest version of FileZilla. Are you completely sure it's not in the /plugins folder? If it is, there will be an error in console.
     
  12. ChatEx is now doing the exact same thing as Pex was previously doing. I just tried updating to version 1.30 of ChatEx but the same thing happens. That is:

    1st loadup of plugin works fine

    2nd loadup onwards causes plugin to not be loaded and file size to change to a ridiculously small size, even when using my own config files.
     
  13. I think I may have narrowed it down to what it is.

    Some plugins I have installed download updates for themselves, and when I load the plugin on the first loadup, thats when it initialises the plugin.

    This might be causing it to break, as it says on the next server restart it will update the plugin, but it doesn't, so I imagine something is stopping that from happening. I will try ChatEx 1.50 now and see if that has any impact as thats the version it is trying to update it.

    EDIT: Yes! I think that seems to be the problem as after updating to the 1.11.2 version of ChatEx the plugin it works fine.

    What through me off is that the plugin says its for version 1.11.2, but I assumed I needed the 1.8 version as I am running the 1.8 protocol hack thing where clients on newer versions can join too. But yeah, thank you for all the help guys, is there anything I can do to help you out at all?
     
    • Like Like x 1
  14. Nothing you can help me with, Glad you found your issue :)