Solved Pex Prefix Help!

Discussion in 'Spigot Help' started by CalicoCactus, Jun 2, 2018.

  1. Hi there, I've used Pex a lot, however my friend has tasked me to finish his pex document, which I did. However, the prefix's won't work... Any idea why? (Other ideas / suggestions are also appreciated) (He just wants 3 groups)

    Code (YAML):
    groups:
      Member
    :
        options
    :
          default
    : true
          prefix
    : '&7[&rMember&7]&r'
        permissions
    :
       - modifyworld.*
        - essentials.rules
        - essentials.motd
        - essentials.afk
        - essentials.back
        - essentials.back.ondeath
        - essentials.delhome
        - essentials.help
        - essentials.home
        - essentials.motd
        - essentials.msg
        - essentials.r
        - essentials.rules
        - essentials.seen
        - essentials.sethome
        - essentials.spawn
        - essentials.suicide
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
      Admin
    :
        options
    :
          prefix
    : '&3&l[&4Admin&3&l]&3'
        permissions
    :
       - '*'
      Owner
    :
        options
    :
          prefix
    : '&1&l[&9Owner&1&l]&6'
        permissions
    :
       - '*'
    schema-version
    : 1
     
    Thanks!
     
  2. Go to essentials a couple lines down there is a green line remove the # before the line and enable prefix/suffix
     
  3. Still didn't work, any other ideas?
     
  4. In the essentials chat area of the essentials config do you have {DISPLAYNAME}?
     
  5. Hello, for the prefix to be displayed separectly from the name you need to write in this form: '&7[&rMember&7]&r ' so the last upper comma is one space more, for the problem i recommend setting up essentials like the above answer.
     
  6. Do you have installed EssentialsChat or another Chat plugin?
     
  7. I have iChat, should I switch over to Essentials Chat?
     
  8. Yes, seeing as iChat is outdates
     
  9. Ok, I've got essentialsx.chat or whatever, let me disable multiverse prefix's and we'll see!
     
  10. Allright, I've got it disabled and as it starts up, can someone tell me if this file works?
    Code (YAML):
    groups:
      Member
    :
        options
    :
          default
    : true
          prefix
    : '&7[&rMember&7]&r'
        permissions
    :
       - modifyworld.*
        - essentials.rules
        - essentials.motd
        - essentials.afk
        - essentials.back
        - essentials.back.ondeath
        - essentials.delhome
        - essentials.help
        - essentials.home
        - essentials.motd
        - essentials.msg
        - essentials.r
        - essentials.rules
        - essentials.seen
        - essentials.sethome
        - essentials.spawn
        - essentials.suicide
        - essentials.tpa
        - essentials.tpaccept
        - essentials.tpahere
        - essentials.tpdeny
      Admin
    :
        options
    :
          default
    : false
          prefix
    : '&3&l[&4Admin&3&l]&3'
        permissions
    :
       - '*'
      Owner
    :
        options
    :
          default
    : false
          prefix
    : '&1&l[&9Owner&1&l]&6'
        permissions
    :
       - '*'
    schema-version
    : 1
    users
    :
      d2dc71a3-8266-4f30-b8e9-59a90a0fe816
    :
        group
    :
       - Admin
        options
    :
          name
    : CalicoCactus
      ebc5f153-8400-43e2-a37d-a9f8f0a239e4
    :
        group
    :
       - Owner
        options
    :
          name
    : AussieOtterYT
     
     
  11. I have it set to:
     
  12. Hot dog everyone, guess what! My friend reset the computer the server was on because he is retarded....
     
  13. What people don't do before installing Pex 90% of the time:
    1. They do not have EssentialsChat Jar in the server, if you are using Essentials instead of EssentialsX you can find the EssentialsChat Jar on Jenkins (download 2x if you are running 1.8 or above).
    2. They do not have prefixes enabled. Essentials default config does not have "add-prefix-suffix: enable" (it has a pound sign before it turning it green) this line is very hidden but is at the top of the essentials config.yml. Enable this and it will fix it.
    3. They do not have prefixes in all worlds. When making a prefix it does not require a world but has an option for it, just in case when add /pex group/user <group/user> prefix <prefix> put quotations around the prefix to make sure (ex. "&4&ki&8[&4Owner&8]&4&ki&r &7").
    4. EssentialsX, EssentialsX is not very compatible with PEX if you do not do it correctly. How I made it work is using an Essentials config I already had and porting it over to EssentialsX.

    If none of these solutions work then a couple things might have happened. 1. You're prefix simply does not work and you have to change it. 2. Version compatibility. 3. Not a solution but a suggestion, check for errors in console, if you find something that's the issue.