[PEx] Remove this [staff] prefix from my actual format?

Discussion in 'Spigot Plugin Help' started by LachGameZ, May 14, 2016.

  1. Edit: Here's the new problem, my old one has been resolved.

    This only happens for the "Staff" rank.

    Chat appears as [staff] (PREFIX) (USERNAME): (MESSAGE)

    How do I remove the [staff] thing from the prefix? My chat plugin doesn't have anything set to put that[staff] thing there, neither pex.
     
    #1 LachGameZ, May 14, 2016
    Last edited: May 14, 2016
  2. This will generally happen, to fix this, remove your pex * and op and then from the console add yourself to the owner group and remove yourself from the builder group (if you are in it) and then give yourself pex * again.
    Good luck :^)
     
  3. Use /pex user (name) (prefix or suffix) "(put prefix/suffix here or leave empty)"
    and that will remove the prefix, if that's what you are asking
    Good luck :^)
     
  4. Thanks for the reply,

    I've already got the prefix I want (which is seperated from the one I wanted to remove)

    Here's an example of what my chat looks like when I'm added to Staff.

    [staff] [STAFF] LachGameZ: Testing chat...

    I want to remove the [staff] part of the formatting.

    Essentials chat format:
    Staff: '&e{USERNAME} &e» &e{MESSAGE}'

    Pex rank (without perms):
    Staff:
    options:
    default: false
    prefix: '&7¤&e&lSTAFF&d&7¤&e '
    suffix: ''

     
  5. Try un-pex starring yourself, getting out of staff group, setting your prefix to "" and then add yourself back in
     
  6. 1. Staff doesn't have access to '*', and I'm only added to staff.
    2. Removing the prefix resaults in the Helper one because Staff inherits Helper.
    3. Nice server, man! Looks like you put loads of time into that.

    The [staff] problem still persists... I've tried everything and nothing works
     
  7. De-opping doesn't work either
     
  8. Hop on my server, we can chat there
     
  9. Okay, I had to deal with this, What version of Essentials are you using? a Fork or what?

    if so, Change to EssentialsX (if you are using the 1.8 fork from a while ago) and it should change. I haven't played minecraft for a while now and just Hopped on and saw this. so try that :) (when changing to essentialsX NOTHING is lost)
     
  10. thanks, i'll try that
     
  11. i'll do that tomorrow, sorry for the late reply haha