Solved PEX unable to use commands even though defining permission nodes in permissions.yml

Discussion in 'Spigot Plugin Help' started by Dark_Onightz, Jun 9, 2016.

  1. So i have tried deleting and reinstalling all the plugins
    i have reinstalled PEX 1.23.4, Essentials and EssentialsChat for now

    i have changed the group default to group Guest in the PEX permissions.yml and set it to default:true(you can check the permissions.txt)
    and added the permission node:
    - essentials.kits.tools

    i tested it and it says the same message:
    "you do not have access to that command"

    im using Spigot1.9(you can also check in the latest.txt)

    There are two permissions.yml:
    - One is located in the PEX folder
    - Second is located in the default folder(i.e with bukkit.yml,plugins folder,etc)

    pls help me in solving this issue :(

    Here is my latest log file and PEX permissions.yml :
     

    Attached Files:

  2. mathhulk

    mathhulk Retired Moderator
    Retired

    Is it just Essentials commands?
     
  3. No..i also tried with other plugins...it still doesnt work.

    When i also enter the /help command it says that i dont have permission to use that command.

    I just want to set permissions for players who are of that group and are limited to use those commands


    When im opped i have all the permissions to use the commands...but when im deopped and im of guest group i dont have permission to use the kit command even though i have set the permission node.
     
    #3 Dark_Onightz, Jun 9, 2016
    Last edited: Jun 9, 2016

  4. watch this vid
     
  5. The problem is that even though i set the permissions for that group..and when i run the command that i have given permission while i am in that group, it always says that
    I dont have access to those codes..
     
  6. i have even done that but never did run pex commands in game...:p
     
  7. #7 hdakhilz, Jun 9, 2016
    Last edited: Jun 9, 2016
  8. Ok i will check it out and inform u guys cuz im not home right now But do we even need permission for running the /help command
     
  9. Yep
    Permission nodes for everything
    Here is the list: http://wiki.ess3.net/wiki/Command_Reference/Perm
     
  10. Guys it worked :)
    i was stupid :p...i wasnt defining the nodes properly..
    Thanx for helping me out :):D:)
     
  11. Your welcome
     
    • Like Like x 1