Web PEXAdmin 1.5

Web-interface to view/edit PermissionsEX data

  1. could you run a phpinfo(); to check if mysql driver is correctly loaded/activated from php.ini, please ?
    Also try with dnf install php-pdo_mysql
  2. I did the phpinfo. It doesn't show anything for MySQL.
    Then I ran the command, and it says that it's already installed.
  3. could you check your php.ini (don't know the exact path in Fedora) and check if these lines are uncommented ?
    Code (Text):
    #23 David191212, Dec 27, 2017
    Last edited: Dec 27, 2017
  4. I was unable to find those in my file.
  5. did you look in /etc/php.d folder ?
    if the folder not exist, don't worry, just add the 2 following lines in the extensions part of your php.ini
    Code (Text):
  6. what are the contents of pdo.ini, pdo-mysql.ini ?
    also could you try php -m and search if PDO and pdo_mysql are loaded ?
  7. I did php -m, and they both showed up.
  8. So they are properly loaded...
    Humm, could you show your db.json file here (with a fake username/password of course)
    I'm running out of ideas :confused:
  9. To summarize the problem:
    - PEXAdmin gives you the 'could not find driver' error
    - php -m says that PDO and pdo_mysql are both loaded
    - the db.json doesn't seem to contain any typos / strange characters

    I'm afraid I don't have any more clues to resolve this problem for now, sorry...
    There's a problem somewhere in your PHP environment, but I don't know where and why :(
  10. After a reinstall of PHP, and restarting the machine. It it starting to work.
  11. So glad it finally worked :)
  12. yes, its an ajax error, could you go to http://YOUR_SERVER/permissions/list?draw=1 and tell me which error do you encouter ?

    When I got this error in my test env here was the possible reasons:
    does the permissions tables exists in the database ?
    If so, do they uses the same name as PermissionEX sql backend config (e.g. alias set ?)
  13. Yay! It works! Thank you!
  14. You're welcome :)

    PS: Don't forget to disable the debug mode when you launch PEXAdmin into production ;)
  15. Oh yea! Thanks for that!