placeholder api issue maybe?

Discussion in 'Spigot Plugin Help' started by prriincess, Aug 17, 2018.

  1. i just bought a server two days ago and am currently installing the plugins i want and configuring them and i'm getting this same warn message over and over that's disabling a bunch of plugins and i don't know what's causing it or how to fix it? i knew nothing about plugins going into this but ive been learning as i go through and this i just can't figure out

    i get this message where it says disabling (plugin)
    Could not pass event PluginDisableEvent to PlaceholderAPI v2.8.2
    this repeats continuously
    this is just one example below

    INFO Disabling Jobs v4.7.2 16.08 18:57:20 [Server]
    ERROR Could not pass event PluginDisableEvent to PlaceholderAPI v2.8.2 16.08 18:57:20 [Server]
    INFO org.bukkit.event.EventException: null 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:500) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:485) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.java.JavaPluginLoader.disablePlugin(JavaPluginLoader.java:355) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.SimplePluginManager.disablePlugin(SimplePluginManager.java:422) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.plugin.SimplePluginManager.disablePlugins(SimplePluginManager.java:415) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at org.bukkit.craftbukkit.v1_12_R1.CraftServer.disablePlugins(CraftServer.java:349) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at net.minecraft.server.v1_12_R1.MinecraftServer.stop(MinecraftServer.java:465) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:613) [spigot-1.12.2-R0.1-SNAPSHOT-b1642.jar:git-Spigot-642f6d2-6103339] 16.08 18:57:20 [Server]
    INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_171] 16.08 18:57:20 [Server]
    INFO Caused by: java.lang.AbstractMethodError: me.clip.placeholderapi.expansion.PlaceholderExpansion.getPlugin()Ljava/lang/String; 16.08 18:57:20 [Server]
    INFO at me.clip.placeholderapi.PlaceholderListener.onPluginUnload(PlaceholderListener.java:113) ~[?:?] 16.08 18:57:20 [Server]
    INFO at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_171]


    not sure if i need to post anything else so whatever someone needs to help me id gladly give
    thanks
     
  2. Try some other version of papi. Also please use pastebin or
    Code (Text):
    The code button
     
  3. use an older version of placeholder?
     
  4. PlaceholderAPI v2.8.2 came out in Jul 16, 2017... since then 7 updates. I would recommend downloading a current version of PAPI.
     
  5. thats the most recent version from the multicraft console lol
     
    • Optimistic Optimistic x 1
  6. Can you install your own plugins? Because if you can you should download the most recent version and use it.
     
  7. But those aren't the OFFICIAL plugin pages.
    The official placeholderapi page is here: https://www.spigotmc.org/resources/placeholderapi.6245/
    After you download, navigate to the FTP section of your multicraft
    Then go to the plugins section and upload the jar that is available right there, but before that delete the old placeholderapi jar.
     
    • Agree Agree x 1