Spigot PlaceholderAPI 2.11.2

A resource that allows information from your favorite plugins be shown practically anywhere!

  1. Yea, unfortunately some of the expansions will state there is an update when there isn't. Looking at the Bungee expansion though, it appears there is an update for it (version 2.0). https://api.extendedclip.com/expansions/bungeecord/

    Something I could suggest is going into the expansions folder and deleting the Bungee file in that folder, restart the server, then try redownloading it again. Hope this helps! ☺
     
  2. interesting writes though that 1.0.1 is above when i installed 2.0 and had server restart and /papi reload as well
     
  3. Hi, what could be the reason for this error message?

    Code (Text):
    [14:16:45 ERROR]: [PlaceholderAPI] failed to load class files of expansions
    java.util.concurrent.CompletionException: java.lang.NoClassDefFoundError: net/ess3/api/IEssentials
            at java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:315) ~[?:?]
            at java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:320) ~[?:?]
            at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1770) ~[?:?]
            at java.util.concurrent.CompletableFuture$AsyncSupply.exec(CompletableFuture.java:1760) ~[?:?]
            at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:373) ~[?:?]
            at java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1176) ~[?:?]
            at java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1647) ~[?:?]
            at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1614) ~[?:?]
            at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:165) ~[?:?]
    Caused by: java.lang.NoClassDefFoundError: net/ess3/api/IEssentials
            at java.lang.Class.getDeclaredMethods0(Native Method) ~[?:?]
            at java.lang.Class.privateGetDeclaredMethods(Class.java:3373) ~[?:?]
            at java.lang.Class.getDeclaredMethods(Class.java:2480) ~[?:?]
            at me.clip.placeholderapi.expansion.manager.LocalExpansionManager.lambda$findExpansionInFile$7(LocalExpansionManager.java:396) ~[PlaceholderAPI-2.11.1.jar:?]
            at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1768) ~[?:?]
            ... 6 more
    Caused by: java.lang.ClassNotFoundException: net.ess3.api.IEssentials
            at java.net.URLClassLoader.findClass(URLClassLoader.java:432) ~[?:?]
            at java.lang.ClassLoader.loadClass(ClassLoader.java:586) ~[?:?]
            at java.lang.ClassLoader.loadClass(ClassLoader.java:519) ~[?:?]
            at java.lang.Class.getDeclaredMethods0(Native Method) ~[?:?]
            at java.lang.Class.privateGetDeclaredMethods(Class.java:3373) ~[?:?]
            at java.lang.Class.getDeclaredMethods(Class.java:2480) ~[?:?]
            at me.clip.placeholderapi.expansion.manager.LocalExpansionManager.lambda$findExpansionInFile$7(LocalExpansionManager.java:396) ~[PlaceholderAPI-2.11.1.jar:?]
            at java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1768) ~[?:?]
            ... 6 more
    If I understand it right a plugin could be compiled with the different java version as the server itself is using. But which one, PlaceholderAPI itself?

    The server is running with JRE17.
     
  4. This usually happens when there's a mismatch in versions between the essentials expansion and essentials itself. Update both to the latest and it should fix that.
     
  5. When using %server_tps% it shifts to *20 *20 *20/ 20 20 20 Is this ServerAPI or am I using the wrong PlaceHolder for what Im wanting(I just want it to say 20 Nothing Else.
    upload_2022-4-20_13-15-47.png
    Using any of theses does not work


    %server_tps%
    %server_tps_1%
    %server_tps_5%
    %server_tps_15%
    %server_tps_1_colored%
    %server_tps_5_colored%
    %server_tps_15_colored%
     
  6. Code (Text):
    [01:16:11 INFO]: [PlaceholderAPI] Successfully registered expansion: playerlist [2.1]
    [01:16:11 WARN]: java.lang.ClassNotFoundException: net.minecraft.server.v1_18_R2.MinecraftServer
    [01:16:11 WARN]:        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:445)
    [01:16:11 WARN]:        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:587)
    [01:16:11 WARN]:        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:520)
    [01:16:11 WARN]:        at java.base/java.lang.Class.forName0(Native Method)
    [01:16:11 WARN]:        at java.base/java.lang.Class.forName(Class.java:375)
    [01:16:11 WARN]:        at com.extendedclip.papi.expansion.server.ServerExpansion.<init>(ServerExpansion.java:63)
    [01:16:11 WARN]:        at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    [01:16:11 WARN]:        at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:77)
    [01:16:11 WARN]:        at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    [01:16:11 WARN]:        at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:499)
    [01:16:11 WARN]:        at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:480)
    [01:16:11 WARN]:        at PlaceholderAPI-2.11.1.jar//me.clip.placeholderapi.expansion.manager.LocalExpansionManager.createExpansionInstance(LocalExpansionManager.java:422)
    [01:16:11 WARN]:        at PlaceholderAPI-2.11.1.jar//me.clip.placeholderapi.expansion.manager.LocalExpansionManager.register(LocalExpansionManager.java:162)
    [01:16:11 WARN]:        at java.base/java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197)
    [01:16:11 WARN]:        at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:179)
    [01:16:11 WARN]:        at java.base/java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1625)
    [01:16:11 WARN]:        at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509)
    [01:16:11 WARN]:        at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499)
    [01:16:11 WARN]:        at java.base/java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:921)
    [01:16:11 WARN]:        at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    [01:16:11 WARN]:        at java.base/java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:682)
    [01:16:11 WARN]:        at PlaceholderAPI-2.11.1.jar//me.clip.placeholderapi.expansion.manager.LocalExpansionManager.lambda$registerAll$4(LocalExpansionManager.java:333)
    [01:16:11 WARN]:        at PlaceholderAPI-2.11.1.jar//me.clip.placeholderapi.util.Futures.lambda$onMainThread$0(Futures.java:46)
    [01:16:11 WARN]:        at org.bukkit.craftbukkit.v1_18_R2.scheduler.CraftTask.run(CraftTask.java:101)
    [01:16:11 WARN]:        at org.bukkit.craftbukkit.v1_18_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:483)
    [01:16:11 WARN]:        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:1188)
    [01:16:11 WARN]:        at net.minecraft.server.MinecraftServer.lambda$spin$1(MinecraftServer.java:320)
    [01:16:11 WARN]:        at java.base/java.lang.Thread.run(Thread.java:833)
     
  7. Heroes Premium plugin
     

    Attached Files:

  8. I have this issue. The other placeholders worked perfectly fine before, but after adding a towny placeholder, it now looks like this. Any help?

    upload_2022-5-18_17-27-37.png
     
  9. Andre_601

    Supporter

    Most likely an issue with your chat plugin.
    Also, please use the HelpChat Discord for support.
     
    • Funny Funny x 1
  10. No worries, solved it. Thanks for the quick reply nevertheless!
     
  11. i wanna make sure im doing this right cause it's not working.

    I want to use %player_name% in the command "luckperms user <playername> group add <groupname>

    I downloaded the luckperms placeholderapi expansion and placed it into the expansion folder. I used "reload ecloud download Player" to get the player placeholders, then "papi reload".

    However its still not allowing me to use "lp user %player_name% group add <groupname>
     
  12. Andre_601

    Supporter

    1. Where are you using the command? Not all plugins support PlaceholderAPI placeholders for commands.
    2. Join the HelpChat discord server for faster support.
     
    • Funny Funny x 1
  13. Oh yeah sorry, I realized that using the expansion for luckperms only let me use certain placeholders that were listed on the luckperms wiki. I know i have other plugins that use placeholder but i cant remember which one. no worries tho, ill figure it out, thanks!
     
  14. Version Server:
    This server is running CraftBukkit version 3484-Spigot-b6d12d1-7bc728a (MC: 1.18.2) (Implementing API version 1.18.2-R0.1-SNAPSHOT)

    Version Papi plugin:
    PlaceholderAPI (2.11.1)

    Error:
    These commands do not return a response.

    Commands:
    /papi parse me %world_nearbyEntities_50%
    /papi parse DonKolia %world_nearbyEntities_50%

    This bug has been around since 1.12.2...thanks for your help.
     

    Attached Files:

  15. Any news for 1.19?
     
  16. Latest release version should work fine on 1.19, let us know if there are any issues.
     
    • Like Like x 2
  17. Good afternoon, if you notice rare words, it is because I am using the translator. Well, I want you to tell me if it is not so much trouble, what would be the most convenient version for 1.12 for the plugin, thanks
     
  18. HelpChat

    Team Account

    HelpChat updated PlaceholderAPI with a new update entry:

    2.11.2 - 1.19 Support, --null parse argument, colour formatting removal and fixes

    Read the rest of this update entry...
     
  19. upload_2022-7-3_17-2-54.png
    @AREA_ The situation was sorted out, they removed the plugin due to the Javascript expansion, which people used to make some potential dangerous scripts.

    upload_2022-7-3_17-3-41.png
    @mrpongi See this https://www.spigotmc.org/threads/placeholder-api-error.550815/#post-4433588

    upload_2022-7-3_17-5-19.png
    @Prozentsatz arguments?

    upload_2022-7-3_17-6-8.png
    @MrKuryn That is just a warning from spigot, can be ignored, it doesn't affect your server in any way.

    upload_2022-7-3_17-6-38.png
    @Tungkgkg123123 Reviews section is not a place to get help. Run the command trough console, or use the new [placeholder] action added to DeluxeMenus. For future reference, use https://helpch.at/discord for help.