Players Can't Pick Up Items

Discussion in 'Server & Community Management' started by KingOfTheEast01, Jul 1, 2017.

  1. Hey guys, my name is Lucas. Lately, my server has been having a dire problem I just can't seem to solve. I recently updated the server to 1.12. When I did so, some of the players on my server found that they couldn't pick up items off the ground. I noticed too, and also realized operators couldn't pick up items either. I decided to go ahead and do some tests on another server of mine on 1.12, while the server that was having problems sits in 1.11.2. I was able to pick up items off of the ground on this server and realized the problem didn't have to do with the version the server was on, but one of the plugins and it's comparability with 1.12. I then went on the server this problem originated on and reverted it back up to 1.12 and disabled all the plugins in groups. I found that none of the plugins were causing the problem as I continuously wasn't able to pick up items as I disabled them all. I have yet to find the issue and believe this has to do with some plugins not having been updated to 1.12, but would like to see if any of you guys could help me speed up the process of figuring out what is going on.

    All help is appreciated. Thanks for any help you can provide! :D
    -Lucas

    Here's a list of all of my plugins


    1.8Pvp (Disabled)
    AcceptRules.ja
    AirBar.jar (Disabled)
    AntiEnderman
    askyblock
    Auction_House
    Banknotes
    BarAPI
    BottledExp
    BuycraftX
    BuySkills
    ChatItem
    citizens
    ClearChat
    Clearlag
    CommandNPC
    CommandWatcher
    Cook
    CratesPlus
    CustomOreGen
    DiscordSRV
    EpicRename
    Essentials
    EssentialsChat
    EssentialsGeoIP
    EssentialsSpawn
    GAListener
    HolographicDisplays
    Lottery.jar
    mcMMO.jar
    MessageAnnouncer
    MobStacker
    MPets (Disabled)
    Multiverse-Core-2.5.0
    MVdWPlaceholderAPI
    ObsidianAuctions
    Parkour (Disabled)
    PermissionsEx
    PlaceholderAPI
    PlayerMention
    PlayerSkulls
    PlayerVaults
    PluginManager
    ProtocolLib
    Scoreboard (Disabled)
    ServerListPlus (Disabled)
    ServerSigns
    ShopChest
    SilkSpawners
    SimpleAPI
    SkyVault (Custom made plugin)
    SRR
    SuperTrails
    Tablist
    Trading
    VanishNoPacket
    Vault
    VentureChat (Disabled)
    Votifier
    Warnings
    WarpPortals
    WhitelistMessage
    WorldEdit
    WorldGuard
     
    • Agree Agree x 1
  2. latiku

    Supporter

    Any messages sent in chat, e.g "you are not permitted to interact with (item)"
     
    • Agree Agree x 1
  3. No, I did think this had to do with AntiBuild or something of the sort, but I remembered I got rid of it a long time ago. There's no error in the console either.
     
  4. Bump, I still haven't found a solution to this problem.
     
  5. Bump. Is anyone else having this problem?
     
  6. "/gamerule doTileDrops true".
     
    • Agree Agree x 1
  7. I'm not sure you understand the problem very well...The tile drops gamerule controls whether or not items drop from blocks. That has nothing to do with this. The items are already on the ground. We just can't pick them up.
     
  8. can you send your log?
     
  9. Check protect spawn in your server config and set it to 0
     
  10. Spawn protection allowes you to pick up items lol
     
  11. It was Worth a shot
     
  12. electronicboy

    IRC Staff

    are you running the latest version of spigot? There was a bug a little while ago that prevented pickups which has since been fixed
     
  13. That's exactly what caused the problem actually. I'll try updating again.

    EDIT: It worked! I updated to 1.12 using the newest file on getbukkit. Thanks so much mate! :D
     
    #13 KingOfTheEast01, Jul 9, 2017
    Last edited: Jul 9, 2017
  14. I have this problem but now on 1.14.4
     
    • Like Like x 2
  15. I also. maybe we should try and update!
     
  16. I'm having this issue with my skyblock server. It only just started happening. What should i do i dont want to have to restart all my stuff because it needs to be 1.12 for certain plugins. Its been weeks and its been fine and all of a sudden its broke.
     
  17. If anyone else has this issue, make sure it's not part of a World Guard region's flags.