Solved PLAYERS GETTING KICKED

Discussion in 'Spigot Plugin Help' started by SladeHazard, Jan 29, 2020.

  1. Server version: 1.12.2 spigot

    I'm using viaversion,viabackwards,viarewind,protocolsupport and protocolsupportlegacysupport= (to add hologram support for 1.7 users)

    Kick error: Symthinical lost connection: Internal Exception: io.netty.handler.codec.EncoderException: MessageToMessageCodec$1 must produce at least one message.

    Problem is caused by protocolsupportlegacysupport 1.7 players get kicked for logging into the server only happens if there are holograms in the server I tried contacting the author but he no longer provides support for lower MC versions so I was hoping maybe someone here knows what's wrong

    What i've already tried:
    Removing all plugins except protocolsupport,protocolsupportlegacysupport,holographicdisplays

    I know that this can be fixed as this plugin is being used on multiple 1.12.2 spigot/paper servers

    Versions:
    ProtocolSupport: 4.29-dev
    ProtocolLIB: 4.4.0
    ViaVersion: 1.4.5
    ViaVersion: 2.2.3
    ViaBackwards: 2.4.0-SNAPSHOT

    P.S Don't recommend viarewind-legacy-support for hologram support viarewind messes with 1.7 causing 1.7 players to get kicked for having their view distance set to a high level (you can even read this on viarewind plugin page in known issues) doesn't happen with protocolsupport though
     
  2. Dropping 1.7 which is a 6+ old version would fix your issue but you probably don't want that.
     
    • Agree Agree x 1
    • Optimistic Optimistic x 1
  3. I dont get why you would even support versions like 1.7 xD
     
    • Agree Agree x 2
    • Optimistic Optimistic x 1
  4. Because versions like 1.7 are good. Versions like 1.14, 1.16 and up are NOT good.
    Keep that in mind :)
     
    • Agree Agree x 1
  5. If you're using ProtocolSupport, why are you using ViaBackwards?

    And why does your list show ViaVersion twice?
     
  6. DOUBLE ViaVersion.
     
  7. Oh, and you can't use ViaVersion and ProtocolSupport together on Spigot.
     
  8. You have stated your opinion with no reason to back it up.

    Trying to support versions as old as 1.7 are likely to bring complications like this, so I would suggest leaving it at 1.8 players.
     
  9. Yikes
     
    • Agree Agree x 1
  10. why would u rpely to this after 2 years...
     
  11. The person who necro'd the thread (didn't even realise myself until you said so, since it's the same month) was @Wolfy_red.
     
  12. For any future people having this problem: it's caused by protocolsupportlegacysupportt which allows support for armor stands to 1.7 user but the code is incorrect for 1.12.2 which kicks them.
     
  13. Yikes is right! If you upgrade your world to 1.14 and up, and the back to 1.13, it completely breaks the world!

    So many issues with the newer versions that are just fixed by making the server 1.14- but letting 1.13+ join the game.
     
    • Agree Agree x 1
  14. Backing evidence like this up is as easy as corrupting my world in a few clicks! If you upgrade your world to 1.14 and up, and the back to 1.13, it completely breaks the world!

    So many issues with the newer versions that are just fixed by making the server 1.14- but letting 1.13+ join the game.
     
    • Agree Agree x 1