Players not getting ranks on joining

Discussion in 'Spigot Plugin Help' started by SkellyX, Jun 10, 2017.

  1. Hey,

    So, I'm in the process of relaunching a gamemode on my server that has been gone for several months. During this process we decided to change the rank names from what they used to be and simply did that via the PEX file by replacing the previous rank names with the new ones. This PEX file is the same one we used previously and still has all the users in there from last time, all we did was switch up the rank names thinking they get their ranks back without us having to manually add them one by one.

    However, when we did a beta recently, the ranks did not instantly apply themselves to the players upon first joining, which I thought they might have. When applying the ranks manually in game they work fine, but seeing as players who had ranks previously have been put into the relevant group in PEX I assumed they'd automatically be set to that group on joining.

    I hope this makes sense. I suspect I'm missing something obvious here. If someone could point out what might be up I'd be most grateful.

    Thanks.
     
  2. Just googled a bit.

    Go to your Permissions file and:
    - Look if there is only one group that has default set to true.
    - Try changing:
    Code (Text):
    Default: true

    #Change it to:

    Default: 'true'
    Or try using the command:
    Code (Text):
    /pex default group [world]

    #Print the default groups for specified world. If [world] is not specified, it will apply to the global config.
     
    #2 Zembrow, Jun 10, 2017
    Last edited: Jun 10, 2017
  3. I've actually just noticed that whenever I do /pex user <name> it doesn't show the group that they're set to in the pex file. The pex file updates if I place them in the group using the in-game command but if I add them to a group via the file it doesn't show in-game, if that makes sense?

    [​IMG]
    In the file this user is in a group. I'm somewhat confused as to why this is happening.
     
  4. Weird...

    Some things that you could do:
    - Do you have an updated version of PEX.
    - It could be an problem that you imported an old Permissions file that maybe did something to PEX???
    - Did you put your Config File trough a YAML Parser, to check if something isn't right.

    I'm not very experienced with PEX because I always use Groupmanager but I could help you via skype maybe a bit better,
    if you're interested PM me.
     
  5. past here your permissions.yml
     
  6. I use PEX. This is something that I did. I just saved my permissions list, recreated the Permissions.yml and I put in all the permissions again, then it worked. PEX can be a hassle sometimes. If that doesn't work try updating to 1.12 as well as PEX, make sure you aren't using 1.8 and bellow versions.
     
  7. I tried deleting my old pex file and creating a new one, and in the process I think I have discovered a problem. I manually added a player's UUID, name and rank (God) in the file, thinking if they'd log in it would apply, it didn't. I then applied a different rank (Elite) in-game using the pex command, upon examining the pex file afterwards I noticed that there were two entries for the player, and they had completely differed UUIDs...

    [​IMG]

    Anybody understand why it might be doing this?
     
  8. What version are you switching from, in the 1.12 pre-5 they switched the way of UUIDS, the could possibly be it whilst the 1.9 version UUIDS were also changed.
     
  9. It is 1.8 but also 1.7-1.12 compatible
     
  10. Send us your current permissions.yml
     
  11. Send current permissions.yml
     
  12. https://pastebin.com/qj28mfmS

    I reset the pex file recently which was when I discovered the UUID issue mentioned above.
     
  13. The UUIDs shouldn't be an issue if they are still in there from last time and they were working. Now for the UUID thing, it will say UUID - rank, if you changed that rank name, you will need to go through and change that all again for the UUIDs. I parsed your permissions file and all seems well.
     
    • Like Like x 1
  14. You don't need to do it in the options.
    Code (Text):
    groups:
      Member:
        default: true
        permissions:
        - permission.1
     
  15. do u use any version of database for multiple servers? cause the permissions file will not get used any more if ur using a database..
     
  16. if ur using via version /protocol lib it might be it
     
  17. sorry but I know what you did wrong you have to change the names of the groups where the player uuids are stored by there name there is a group there change that to the name of the new group name that you like hope this helps
     
  18. Oh that is in the perms file btw so at the bottom of the file where the players are placed
     
  19. If you need one rank you can set them to default rank.
     
  20. Ohh wait, You can use CustomJoinitems. then you can set a command on joining. So if you want to set a player to Player rank. you set /pex user {name} group Player.