Players unable to join w/ 1.8 client.

Discussion in 'Server & Community Management' started by Qruet, May 28, 2018.

  1. My server supports versions 1.7-1.12.2, the server itself however is based on spigot 1.12.2 - latest build. The problem that is occurring is exactly as explained in the title, players who attempt to join with the 1.8 (1.8 - 1.8.9) (vanilla or modded) client are kicked every time with either the following message:
    Code (Text):
    Internal Exception: java.io.IOException: An existing connection was forcibly closed by the remote host
    or occasionally a timed out message.

    I've found that this issue is probably not due to a plugin since I've went through and disabled quite a few. I originally came to the conclusion that it was being caused by AACAdditionPro (Latest version) since after countless tests with it being uninstalled the issue stopped occurring. That was before I realized I was on a fairly old version, when I updated the addon to its latest version and reenabled the plugin, there was no evidence of the issue. However, after a few restarts later the issue once again continued with the same error. I uninstalled both the addon and then the anticheat (AAC) itself, however that resolved nothing. I've tried uninstalling countless plugins with no luck, however occasionally after perhaps a few other restarts the issue disappears for no apparent reason. Therefore there appears to be no pattern that I can notice so far with the issue.

    Perhaps someone may have a better clue as to what may be causing the issue.
     
  2. Do all players randomly get this? Or only players using a certain MC Version?

    Edit: If only players to certain MC version, what version would that be please :D
     
  3. Please read my post.
     
    #3 Qruet, May 28, 2018
    Last edited: May 28, 2018
  4. I did read it, just had a brain fart. Sorry mate, will leave it to someone else.
     
  5. I am assuming you are using ViaVersion and ViaBackwards correct?
     
  6. I think 1.8 players shouldn't even be able to join that or are my eyes wrong?
    [​IMG]
     
    • Winner Winner x 1
  7. Fair point there, the server has to be running 1.8 or above for users to connect with other versions, and 1.7 isn't supported by ViaVersion. What I don't understand is why you would support 1.7, no one uses it anymore and it is extremely outdated, especially with the coming release of 1.13
     
  8. The same can be said about 1.8, 1.9, 1.10, 1.11.
     
    • Agree Agree x 1
  9. I am using ViaVersion ViaBackwards and ViaRewind. I've been using it also on my development server and that has provided me with no issues with clients from 1.7-1.12.2 (using same spigot version and plugin versions as my other server). Unless there's some sort of conflicting error which doesnt appear present with any stacktrace errors in console, then I doubt it's due to those plugins, although Im still open to the possibility of them being the cause of the issue since that would make sense. I also agree that 1.7 is extremely outdated however ViaRewind which I needed to enable backwards compatability with client versions from 1.8 and up which viabackwards doesnt enable (Only 1.9+), however it so happens viarewind also includes support for 1.7 which I may disable later.
     
    #9 Qruet, May 29, 2018
    Last edited: May 29, 2018
  10. I wish players liked to play on the latest version but you'd be surprised by the number of players who like to play on 1.8 or even 1.7 clients, due to the reason that "the pvp mechanics are better", or at least it's the only pvp mechanics that they are used too and aren't willing to take the time to adapt to the new mechanics. I would say that a large percentage of players still play on 1.8 just so that they may click as rapidly as possible without having to worry about the 1.9 implemented hit delay.
     
  11. Choco

    Moderator

    Then start making a change and kill off their playerbase by not supporting it. You and other large servers (Hypixel, namely) are the reason these playerbases still exists. It's because servers are encouraging them to use that version. You're putting your server at a huge inconvenience supporting such outdated software and limiting your 1.12 players to 1.7 features. The more servers that drop the outdated versions, the less places they'll have to go.
     
    • Agree Agree x 2
  12. 1.12.2 players experience all the features that 1.12.2 has too offer, the blocks, items, etc. on the server since the server runs on the lastest spigot build, however I do agree that the mindset of 1.7 still being an acceptable version to play on isnt appropriate. I will probably disable support for this version soon , however before this thread goes off topic as too what version should be supported or why players support so and so versions, I want to remind everyone that I am still looking to resolve the issue for my 1.8 clients.
     
    #12 Qruet, May 29, 2018
    Last edited: May 29, 2018