Solved Plenty of ram, plugins upto date, yet 12-18~ TPS?

Discussion in 'Spigot Help' started by Prince4DX, May 22, 2016.

  1. Hello,
    So my servers been running fine for over 2 months. Suddenly one morning the servers tps is horrendous. 3 Days ago it was perfect and I didn't touch or edit anything since, I've tried removing plugins removing all mobs etc.. Nothing changes. From what I noticed the servers tps drops by 2~ every time a new player joins but that's about all I've come to notice.

    Restarting doesn't help starts at 19 and goes down slowly with 5gb ram free. I've started deleting plugins which didn't change anything either. Console also has no errors, clean start up and shutdown.

    Timings: https://timings.spigotmc.org/?url=16609234

    Help much appreciated thanks!
     
  2. Do you have the same problem without any plugins?
     
    • Like Like x 1
  3. I'll try, its hard to kick 30 and delete plugins etc.. lol
     
  4. Just temporarily rename your plugin folder to something different ;)
     
    • Like Like x 1
  5. dammit, I already backed everything up and was deleting and uploading 1 by 1 with a restart lol

    could of said something xD
     
  6. JamesJ

    Supporter

    Read the massive red message at the top of the timings?

    Notice: Your AVG TPS is less than 19 but server load is less than 95. This may mean your server is having memory issues (leak or not enough).
    This is usually a sign that Java is spending too much time Garbage Collecting. Try using -XX:+UseG1GC -XX:MaxGCPauseMillis=50 flags and increasing your -Xmx.


    Usually helps a lot, rather than getting other people to do it for you.
    Try disabling each plugin one-by-one, and identifying which is causing the most problems.
     
  7. Working on it currently
     
  8. I think I found the problem (Battlelevels) I'm tipple checking before I get exited/relieved. lol

    Half found it, Coloured Anvils was also part of the problem. The servers tps is now at 19 mostly dips to 12 rarely and goes to 18 sometimes. With no plugins or only essentials and worldguard it stays at 20tps. I literally cannot find the problem.
     
    #8 Prince4DX, May 22, 2016
    Last edited: May 22, 2016
  9. No plugins on the server and I changed the jar. Still getting the crappy tps,10. Does this help? lol
     
  10. Have you installed a Clearlag plugin?
     
  11. In addition to the above, your TPS can drop like that if someone who has fly and speed 10 starts flying through ungenerated chunks. What I do to avoid that is use World Borders fill command to generate all of the chunks at a decent pace. It watches your servers speed while it's doing its thing, so it shouldn't crash anything.

    Not sure if that's what causes your problems, but it should help.

    PS: If you do backups of your server (which is smart) doing this will make your world files massive, so backups will take a lot longer.
     
  12. lol, the problem is not located there. I appreciate the thought though!

    I've pre-loaded my whole map due to the fact that I'm using EpicWorldGenerator. When backing up as you said the world file becomes huge I've stuck to only a schematic of spawn and a plugins folder download.
     
  13. DO you use shared hosting? Your server could be getting affected by other shared servers if you have an awful host company. Other than that I have no idea what's causing it.
     
  14. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Please don't your bump your thread that often.
    It's very likely that a players uses tp to get to high coordinates like tp 44444 90 44444
    Servers needs to genrate and load a lot of chunks...

    Check your server log for teleport messages.

    Ways to resolve this:
    • actually set your worldborder. You have worldborder installed, so use it:p Generate chunks with /wb fill
      This makes sure, that the server doesn't have to generate chunks if a players uses the teleport command.
    • Limit /tp to staffmembers
    This doesn't lag your server
     
  15. I'll contact my host.

    I've got a world boarder of 12k and the whole map is pre generated, lastly I did. Thanks!
     
  16. The thing with Java is, if it has 25GB of RAM it goes veryyyyyy sllloowwwwllllyyy because it has to process all the ram. Try decreasing the RAM amount little by little.
     
  17. Problem was on the host's end there fixing it for me, thanks for the help. I'll see if the problem persists after there 'fix'
     
  18. Ahahah are using omgserv
    ?
     
  19. ovh.

    This is resolved, don't reply anymore thank you!