Spigot Plot2Dynmap 5.2

PlotSquared dynmap extension

  1. Empire92 submitted a new resource:

    Plot2Dynmap - PlotSquared dynmap extension

    Read more about this resource...
     
  2. Hi, is it possible to show the player construction on dynmap??

    I see the plots owner, helpers, trusted, etc, but I see black plots instead of waht player build on thei pot, is it normal?

    Thank you
     
  3. Sorry for the lack of a response. The plugin has been updated and should be compatible with the latest version of PlotSquared.
    You need to tell dynmap to do a full world render:
    /dynmap fullrender <world>
     
    • Winner Winner x 1
  4. Are you going to update this one too? :3
    Just installed the latest PlotSquared and that broke the Dynmap plugin
     
  5. This was just updated, just no changelog. If you still have issues, let me know.
     
  6. Code (Text):
    [18:37:23] [Server thread/INFO]: [PlotSquared] Loading PlotSquared v2.8.1
    ...
    [18:37:23] [Server thread/INFO]: PlotSquared is now enabled
    ...
    [18:37:26] [Server thread/INFO]: [Plot2Dynmap] Enabling Plot2Dynmap v2.8.1
    [18:37:26] [Server thread/ERROR]: [Plot2Dynmap] [Plot^2] PlotSquared not found, disabling Plot2Dynmap
     
  7. Sorry. Has been fixed now.
     
    • Like Like x 1
  8. Breaks with the lastest build of PlotSquared (v2.8.5)

    Code (Text):
    [03:31:09] [Server thread/INFO]: [Plot2Dynmap] Enabling Plot2Dynmap v1.0.5
    [03:31:09] [Server thread/ERROR]: Error occurred while enabling Plot2Dynmap v1.0.5 (Is it up to date?)
    java.lang.NoClassDefFoundError: com/intellectualcrafters/plot/api/PlotAPI
        at com.empcraft.plot2dynmap.Main.onEnable(Main.java:327) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugin(CraftServer.java:356) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at org.bukkit.craftbukkit.v1_8_R1.CraftServer.enablePlugins(CraftServer.java:316) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at net.minecraft.server.v1_8_R1.MinecraftServer.q(MinecraftServer.java:402) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at net.minecraft.server.v1_8_R1.MinecraftServer.k(MinecraftServer.java:370) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at net.minecraft.server.v1_8_R1.MinecraftServer.a(MinecraftServer.java:325) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:211) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at java.lang.Thread.run(Unknown Source) [?:1.7.0_72]
    Caused by: java.lang.ClassNotFoundException: com.intellectualcrafters.plot.api.PlotAPI
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_72]
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_72]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_72]
        at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_72]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8-R0.1-SNAPSHOT.jar:git-Spigot-15fa8e1-17a3db7]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_72]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_72]
        ... 12 more
     
  9. Please download the latest version of Plot2Dynmap.
     
  10. [​IMG]
    I'm getting this every 30 seconds in console which is the update period of Plot2Dynmap. I was thinking it was an issue when Plot2Dynmap requested an update from PlotSquared for Dynmap but requested something that was not there.

    Other than the console being spammed every 30 seconds, I see no other side-effects. It is just ugly and I would love to see if there is a resolution for it.
     
  11. Do you have any plots in worlds that aren't loaded on the server?
     
  12. I ended up resetting the plot data for PlotSquared and that worked. I unloaded, deleted, and made sure every config for everything did not include other maps, but it still gave the error.

    If it occurs again I will ask again, because making sure everything was unloaded and that PlotSquared only loaded that one map did not fix it.
     
  13. For future reference, I wasn't recommending to unload the other maps. I was proposing that you might have plots in your database for maps that aren't being loaded. It should have displayed a message during startup which recommends creating the world or using the purge command. I'm not sure if the error obscured this however.
     
  14. Sorry for not clarifying. Deleting them was not my first step. I went first and tried to unload them via multiverse but noticed I had excess maps not even in a folder anymore. I did go under PlotSquared and saw no other plot maps so I don't know what was wrong.
     
  15. Great plugin, always cool to see who's up to what where. After updating PlotSquared to 2.11.23 however, it seems to have died on me:

    • [15:27:34 WARN]:[Plot2Dynmap] Task #61 for Plot2Dynmap v2.11 generated an exception
    • java.lang.NoSuchMethodError: com.intellectualcrafters.plot.flag.FlagManager.getPlotFlags(Lcom/intellectualcrafters/plot/object/Plot;)Ljava/util/Set;
    • at com.empcraft.plot2dynmap.Main.updatePlots(Main.java:277) ~[?:?]
    • at com.empcraft.plot2dynmap.Main.access$1(Main.java:204) ~[?:?]
    • at com.empcraft.plot2dynmap.Main$Plot2Update.run(Main.java:98) ~[?:?]
    • at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:726) [spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:367) [spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:657) [spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:560) [spigot-R0.1-d2856ae9c21.jar:git-Spigot-d2856ae-8f0f4ed]
    • at java.lang.Thread.run(Thread.java:745) [?:1.8.0_45]

    Thanks for your work on this.
     
  16. @XpanD
    Has been fixed, please download the latest version of Plot2Dynmap
     
  17. Thanks! Gonna nab that later. :)

    EDIT: Working well, again!
     
    #19 XpanD, Jun 24, 2015
    Last edited: Jun 25, 2015
  18. cowgod

    Supporter

    This plugin is AWESOME! I have one small issue. The %helpers% variable does not seem to get substituted on the tooltip. Did I mess something up or is this actually a bug?

    Also, where can I donate to you @Empire92?