PlotSquared not working

Discussion in 'Spigot Plugin Help' started by TGSghost24, Feb 25, 2020.

  1. Hello so i have been looking for a creative plot plugin and i came across plotsquared but when i load my server I get a error saying failed to enable plugin anyone know how to fix this.
     
  2. Can you send the error?
     
    • Agree Agree x 1
  3. Hello this is all it says in the console about it

    [08:51:49] [Server thread/ERROR]: Error occurred while enabling PlotSquared v4.453 (Is it up to date?)
    78 java.lang.BootstrapMethodError: java.lang.IllegalAccessError: no such method: com.github.intellectualsites.plotsquared.bukkit.util.BukkitUtil.getPlayer(Player)PlotPlayer/invokeStatic
    79 at com.github.intellectualsites.plotsquared.bukkit.BukkitMain.onEnable(BukkitMain.java:151) ~[?:?]
    80 at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) ~[minecraft_server.jar:git-Spigot-6016ac7-10c10b3]
    81 at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [minecraft_server.jar:git-Spigot-6016ac7-10c10b3]
    82
     
  4. but also it says that the commands are in the game when i do /plot and hit tab but if i do /plot it does nothing
     
  5. PlotSquared v4.453 is for Spigot 1.13+.

    What version of Spigot is your server running? A google search for "minecraft_server.jar:git-Spigot-6016ac7-10c10b3" implies its running 1.10!
     
  6. yeah i use 1.10 but i have never had a problem with plugins that run on a different verison and i use aternos server hosting and i dont get given the option of the older version
     
  7. Well there is no other fix for it. The versions are incompatible, so you either need to upgrade the server to 1.15.2 or get the version of PlotSquared for 1.10. But really there is no reason to be still on 1.10.
     
    • Agree Agree x 1
  8. The main reason i use 1.10 is because i find 1.14/1.15 multiverse don't work do you know if there is an other multi world plugin
     
  9. is there a download for it on spigot or bukkit.
     
  10. Expect yourself to get problems with plugins.
    Here's PlotSquared 1.8 - 1.12.2
    https://intellectualsites.github.io/download/plots.html
     
  11. your spigot version is up to date bro.