Spigot PlotSquared v4: v6 out now! 4.4.495

The best plot plugin available for Minecraft.

  1. When a player use right-click he get twice the "no_permission_event" and "flag_tutorial_usage"-messages. Can you please fix it? Or anywhere know, why?
     
  2. Oke i have a strange problem. Why can normal players build on a plot where they are not owner of or do not have the builder option?
     
    #3123 Duqino, May 4, 2016
    Last edited: May 4, 2016
  3. Dude this plugin has gone to the dogs. we had to close creative for a month and still no new updates that fixed our issues. Closing the server cut our player count right down and since then the problems have persisted, whether its plots getting randomly wiped, new players being able to claim already claimed and heavily built up plots belonging to long standing players, /plot clear erasing the surrounding roads as well as the plot down to the empty void, plots unclaiming themselves. Its just ridiculous. Talks have been had about possibly returning to plotme, though its not something we want to do as that plugin is just as bad. Other than that the only option available to us is to try and build a plot system that works ourselves because at this current time this plugin is a piece of junk. we are using 1.9 with the latest build for that version.
     
  4. I had this problem to. We just did a clean install and everything is running fine now on my creative server.
     
  5. ssamjh

    Moderator

    I think people have asked this before, but is there a way to make the first plot free???
     
  6. You must define the flag "use" in the confi.yml of plotsquared.
    e.g.


    flags:
    use: 55,58,64,
     
  7. Have the world a defined flag in worldguard?
     
  8. No flags - vanila config (worldguard)
     
  9. Can I sea the confi, please?
     
  10. Because you have in minecraft 1.9 a right-hand and a left-hand. A bug-fix was great. :)
     
  11. Any one knows how to turn of the place flag? Looks like its on by default for everyone in the dev build.... Players can build on all plots. But cant destroy anything.

    Edit

    My config:

    http://pastebin.com/BrqwL5a4
     
    #3133 Duqino, May 6, 2016
    Last edited: May 6, 2016
  12. Don't use the dev builds unless you are willing to run an unstable version of the plugin. I think I just fixed it in the newest build though.
     
  13. Looks like the bug has bin fixed!

    Thanks!!!!!!!!!!!
     
  14. Oke its not 100% solved. I just found out you can place redstone, heads and doors (thats all for now)
     
  15. how to del all unknow???

    Usage: /plot purge world:<world> area:<area> id:<id> owner:<owner> shared:<shared> unknown:[true|false]

    can you give me a ExampleCMD
     
  16. ssamjh

    Moderator

    I feel so ignored.

    Edit: found a weird bug! If a player is untrusted but has admin permissions they can place fire on a plot.
    If the player is trusted and does or doesn't have admin permissons they can't place fire.
     
    #3138 ssamjh, May 8, 2016
    Last edited: Jan 24, 2018
    • Agree Agree x 1
  17. I think no.
     
    • Optimistic Optimistic x 1
  18. Yes, I have the Bug too. Thank you for the report.


    Question:
    How I can give the user the permission for use a clickable hologramm (right-click) in my plot? I have set the flag "use: all" and the user can use all, but not for the hologramm. And yes, the NoPermissionsMessages cam from PlotSquared.


    Edit:

    I have set the follow flags on ym plot to true:

    player-interact
    hostile-interact
    animal-interact
    tamed-interact
    misc-interact
    device-interact

    But the user get the messages: "You dow't have the permissions: plots.admin.interact.other"
     
    #3140 RedstoneFuture, May 8, 2016
    Last edited: May 8, 2016