Spigot PlotSquared v4: v6 out now! 4.4.495

The best plot plugin available for Minecraft.

  1. The TNT did not break any blocks. So how can I enable that?
  2. It is a flag, do /p flag list and you should find it there.
    • Informative Informative x 1
  3. Ohh thank you, will try it out!
    EDIT: I tried it, it worked for that one plot. But, I want it to work for all plots not only the plot that I was standing on and ran that command!

    In the setting.yml I found a tab called flags! How can I add the explosion flag to that as true? What is the syntax?
    #3163 limminyo, May 13, 2016
    Last edited: May 13, 2016
  4. it does not fully support the running version 1.9.4 :(
  5. The dev version appears to (at least basic functionality), we don't have 1.9.4 in live yet, but the dev version plays nice with 1.9.4 in test!
    • Like Like x 1
  6. Does the plugin automatically implement compatibility with name changing(uuid) or is there a setting we need to make?
  7. How do I add the explosion:true flag in the settings.yml?
  8. Should be automatic as it fully uses UUID, as far as I'm aware.
  9. The syntax can be found on the wiki page. (link in the resource page)
    • Informative Informative x 1
  10. I was on the Wiki and I found the syntax too, but I was tying the number spaces wrong. But then I copy pasted it and it worked. I had asked this question on a new thread and now it is resolved! Thanks! https://www.spigotmc.org/threads/the-tnt-wont-damage-blocks.147165/
    • Like Like x 1
  11. Ok here comes an idiotic question...I imported a schematic into my plot, the schematic had fireplaces with three lit blocks of netherrack.

    But now only the middle block is lit. I cannot relight them. I disabled WorldGuard and my ice melted but I still wasn't able to light any blocks (yes I have lighters set to allow).

    I disabled MVCore and that made no difference.

    I disabled PlotSquared though, and my house started actually burning and I could use my flint and steel.

    I looked at the flags for PS but don't see any related to fire spread / ignition.

    I know its something pretty obvious but I'm just not able to sort it out ...long day for sure. Any help would be appreciated.
  12. I'm currently running Spigot 1.9. Whenever I type /plot auto or /plot claim, this happens:
    Code (Text):
    [09:57:09] [Server thread/INFO]: Permanently issued server command: /plot claim
    [09:57:09] [Server thread/WARN]: java.lang.StringIndexOutOfBoundsException: String index out of range: -2
    [09:57:09] [Server thread/WARN]:     at java.lang.String.substring(String.java:1931)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.object.Plot.guessOwner(Plot.java:1950)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.object.Plot.canClaim(Plot.java:1927)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.commands.Claim.onCommand(Claim.java:67)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.commands.Claim.onCommand(Claim.java:34)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.commands.MainCommand.handle(MainCommand.java:450)
    [09:57:09] [Server thread/WARN]:     at com.intellectualcrafters.plot.commands.MainCommand.onCommand(MainCommand.java:303)
    [09:57:09] [Server thread/WARN]:     at com.plotsquared.bukkit.util.BukkitCommand.onCommand(BukkitCommand.java:37)
    [09:57:09] [Server thread/WARN]:     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44)
    [09:57:09] [Server thread/WARN]:     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141)
    [09:57:09] [Server thread/WARN]:     at org.bukkit.craftbukkit.v1_9_R1.CraftServer.dispatchCommand(CraftServer.java:645)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.PlayerConnection.handleCommand(PlayerConnection.java:1302)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1137)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:45)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:1)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.PlayerConnectionUtils$1.run(SourceFile:13)
    [09:57:09] [Server thread/WARN]:     at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    [09:57:09] [Server thread/WARN]:     at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.SystemUtils.a(SourceFile:45)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:716)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:655)
    [09:57:09] [Server thread/WARN]:     at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:554)
    [09:57:09] [Server thread/WARN]:     at java.lang.Thread.run(Thread.java:745)
    Any solutions?
  13. can you add whem i switching from Plotme to PlotSquared the land is taken over all owner because where I was the last time that I Try it has Failed to none of Plotme plots were no longer owner so they can add the all the at Plotme one or had several plots also get these world in stay so that the land remain Claimed does it work?
    • Like Like x 1
  14. One gets when a plot always enters the message, who it belongs to. How can I disable it?
  15. ssamjh


    Check the language file.
  16. And what exactly please me to adjust or remove it?
  17. ssamjh


    Edit PlotSquared.use_THIS.yml and change the lines to what you want. This is the settings I use, but if you want to disable them, then just make them empty.
    Code (Text):
      title_entered_plot: ''
      title_entered_plot_sub: $4Created by %s
  18. Thnx, but i have in settings.yml this found: titles: false

    and now working !
  19. ssamjh


    Oh, that will work too.
  20. pls update to Bukkit 1.9.4. Thnx
    • Agree Agree x 1